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文档首页/ Web应用防火墙 WAF/ 故障排除/ 网站接入异常排查/ 域名/IP接入状态显示“未接入”,如何处理?
更新时间:2025-01-17 GMT+08:00

域名/IP接入状态显示“未接入”,如何处理?

故障现象

添加防护域名或IP后,域名或IP接入WAF失败,即防护网站“接入状态”显示“未接入”

  • WAF每隔一小时就会自动检测防护网站的 接入状态,当WAF统计防护网站在5分钟内达到20次访问请求时,将认定该防护网站已成功接入WAF。
  • WAF默认只检测两周内新增或更新的域名的接入状态,如果域名创建时间在两周前,且最近两周内没有任何修改,您可以在“接入状态”栏,单击,手动刷新接入状态。

云模式排查思路和处理建议

防护网站的“部署模式”“云模式”时,请参考图1表1进行排查处理。

图1 云模式排查思路
表1 接入WAF失败问题处理

可能原因

处理建议

原因一:域名“接入状态”未刷新

在防护网站“接入状态”栏,单击刷新状态。

原因二:访问流量未达到WAF统计要求

须知:

防护网站接入WAF后,当WAF统计防护网站在5分钟内有20次请求时,将认定该防护网站已接入WAF。

  1. 在1分钟内多次访问防护网站。
  2. 在防护网站“接入状态”栏,单击刷新状态。

原因三:域名参数配置错误

须知:
WAF支持防护以下类型域名:
  • 一级域名,例如,example.com
  • 单域名/二级域名等子域名,例如,www.example.com
  • 泛域名,例如,*.example.com

example.com与www.example.com是不同的域名,请确认“防护域名”配置正确。

请参照以下步骤确保域名参数配置正确。

  1. 在Windows操作系统中,选择开始 > 运行,在弹出框中输入“cmd”,按“Enter”,进入命令提示符窗口。
  2. 运行ping 域名在WAF对应的CNAME(例如ping e59e684e2278043ae98a5423aef8ee329.vip.huaweicloudwaf.com),获取WAF的IP。
  3. 用文本编辑器打开hosts文件,hosts文件一般位于“C:\Windows\System32\drivers\etc\”路径下。
  4. 在hosts文件添加记录:防护域名 域名对应的WAF的IP
  5. 修改hosts文件后保存,在命令提示符窗口中运行ping 防护域名(例如ping www.example.com)。

    如果回显信息中的IP地址为2中的WAFIP地址,说明域名参数配置正确。

如果域名参数配置错误,删除该域名后重新添加防护网站。

原因四:未配置域名解析或代理回源地址

确认接入WAF的网站是否使用高防、CDN、云加速等代理。
  • 是:确保网站的“是否使用七层代理”已配置为“是”
    • 将CDN等代理回源地址修改为WAF的“CNAME”
    • (可选)在DNS服务商处添加一条WAF的“子域名”“TXT记录”
  • 否:到该域名的DNS服务商处,配置防护域名的别名解析。

详细操作请参见域名接入WAF

原因五:域名解析或代理回源地址配置错误

请参照以下步骤验证域名的CNAME是否配置成功。

  1. 在Windows操作系统中,选择开始 > 运行,在弹出框中输入“cmd”,按“Enter”,进入命令提示符窗口。
  2. 执行nslookup命令,查询CNAME。

    如果回显信息的域名在WAF上的CNAME,则表示配置成功。

    以域名www.example.com为例。

    nslookup www.example.com

如果CNAME配置失败,请参见域名接入WAF重新修改DNS解析或代理服务的回源地址。

独享模式排查思路和处理建议

防护网站的“部署模式”“独享模式”时,请参考图2表2进行排查处理。

图2 独享模式排查思路
表2 独享模式接入WAF失败问题处理

可能原因

处理建议

原因一:域名/IP“接入状态”未刷新

在防护网站“接入状态”栏,单击刷新状态。

原因二:访问流量未达到WAF统计要求

须知:

防护网站接入WAF后,当WAF统计防护网站在5分钟内有20次请求时,将认定该防护网站已接入WAF。

  1. 在1分钟内多次访问防护网站。
  2. 在防护网站“接入状态”栏,单击刷新状态。

原因三:域名/IP参数配置错误

查看基本信息,检查域名/IP参数是否正确。

如果域名/IP配置错误,删除该域名/IP后重新添加防护网站。

原因四:没有为独享模式实例配置负载均衡,配置的负载均衡未绑定弹性公网IP

  1. 为独享引擎实例配置负载均衡
  2. 为弹性负载均衡绑定弹性公网IP

原因五:独享模式实例负载均衡配置错误或负载均衡绑定弹性公网IP错误

云模式-ELB接入排查思路和处理建议

防护网站的“部署模式”“云模式-ELB接入”时,请参考图3表3进行排查处理。

图3 云模式-ELB接入排查思路
表3 云模式-ELB接入WAF失败问题处理

可能原因

处理建议

原因一:域名/IP“接入状态”未刷新

在防护网站“接入状态”栏,单击刷新状态。

原因二:访问流量未达到WAF统计要求

须知:

防护网站接入WAF后,当WAF统计防护网站在5分钟内有20次请求时,将认定该防护网站已接入WAF。

  1. 在1分钟内多次访问防护网站。
  2. 在防护网站“接入状态”栏,单击刷新状态。

原因三:域名/IP参数配置错误

查看域名基本信息,检查域名/IP参数是否正确。

如果域名/IP配置错误,删除该域名/IP后重新添加防护网站。

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