The Client Log Contains "TCP Failed"
Symptom
A client cannot connect to a P2C VPN gateway, and the log contains the following error information:
TCP: connect to [AF_INET] *.*.*.*:**** failed: Unknown error
Possible Causes
The protocol or port number in the client configuration file is different from that configured on the Server tab page of the VPN gateway.
Procedure
Log in to the Huawei Cloud console, locate the target VPN gateway, and check whether the server protocol and port are the same as those in the client configuration file. If not, download the client configuration file again or directly modify the client configuration file, and then use the new client configuration file to reconnect the client to the VPN gateway.
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