更新时间:2023-09-14 GMT+08:00
Manager页面加载卡顿
用户问题
MRS集群Manager页面加载卡顿。
问题现象
登录MRS集群的Manager页面,单击一个按钮需要等一分钟后才能加载到数据,部分按钮单击后卡顿无法访问。
原因分析
查看“/var/log/Bigdata/omm/oms/pms/scriptlog/pms_script.log”,“/var/log/Bigdata/omm/oms/pms/pms.log”日志内容类似如下:
发现日志中有内存溢出的现象,判断是由于PMS内存不足导致Manager界面出现卡顿。
处理步骤
- 以omm用户登录主管理节点。
- 执行以下命令打开application.properties文件。
vi ${BIGDATA_HOME}/om-server_*/OMS/workspace0/conf/pms/application.properties
- 将PMS进程的内存配置参数“pms.mem”根据实际情况调大,保存并退出。
... pms.mem=800m
修改的新值的增长量不能大于操作系统可用剩余内存。
- 执行以下命令查找PMS进程的PID,并终止PMS进程,等待进程重新启动。
ps -ef | grep pms
kill -9 PID
- 登录Manager页面,查看卡顿情况消失。
父主题: 登录集群Manager常见异常问题