更新时间:2022-12-08 GMT+08:00

Manager界面登录用户被锁如何解锁

问题现象

  1. Manager登录时显示:这个账户已经被锁住了,请联系系统管理员来重新获得访问权限。
  2. Manager界面登录用户被锁,导致作业无法提交并无法进入Manager页面。
  3. 通过后台提交作业执行kinit 用户名操作时提示如下异常:
    kinit: Clients credentials have been revoked while getting initial credentials

原因分析

用户登录Manager账户密码错误次数超过限制,账户被锁。

处理步骤

  1. 登录kadmin后台管理控制台。

    1. root用户登录安装了客户端的节点,执行以下命令,切换到客户端目录,例如“/opt/client”。

      cd /opt/client

    2. 执行以下命令,配置环境变量。

      source bigdata_env

    3. 执行以下命令,输入kadmin/admin用户密码后进入kadmin控制台。

      kadmin -p kadmin/admin

      3.x及之后版本默认密码:Admin@123。3.x之前版本默认密码:KAdmin@123。

      首次登录后会提示该密码过期,请按照提示修改密码并妥善保存。

  2. 执行以下命令 ,查看被锁用户数据密码错误次数“Failed password attempts”参数值是否大于或等于5,如果是,则证明账户被锁。

    getprinc 被锁用户名

  3. 如果账户被锁,执行以下命令解锁用户后,重新登录Manager。

    modprinc -unlock 被锁用户名