更新时间:2024-10-30 GMT+08:00
远程连接Windows云服务器报错:此计算机无法连接到远程计算机
问题描述
使用远程登录方式连接登录Windows云服务器时出现如下错误:此计算机无法连接到远程计算机。
图1 无法连接到远程计算机
可能原因
- 服务端安全组3389端口未开启。检查云服务器端口配置
- 服务端防火墙关闭。检查防火墙配置是否正常
- 远程桌面连接配置不正确。检查远程桌面连接设置
- 未开启“Remote Desktop Services”。检查Remote Desktop Services
- 远程桌面会话主机配置不正确。检查远程桌面会话主机
检查云服务器端口配置
检查云服务器的3389端口是否能够访问(默认使用3389端口)。
请确保入方向规则中已添加3389端口。
在云服务器的详情页面选择“安全组”页签,查看安全组入方向规则中已添加3389端口。
检查防火墙配置是否正常
检查云服务器的防火墙是否开启。
- 在控制台使用VNC方式登录Windows云服务器。
- 单击桌面左下角的Windows图标,选择“控制面板 > Windows防火墙”。
图2 Windows防火墙
- 单击“启用或关闭Windows防火墙”。
图3 查看防火墙状态
如果选择开启防火墙,请继续执行以下操作步骤。
- 单击“高级配置”。
- 检查“入站规则”,请确保已启用如下规则。
- 远程桌面(TCP-In) 公用
- 远程桌面(TCP-In) 域,专用
图4 入站规则
如果防火墙入站规则中设置的端口与远程服务器设置的端口不一致,远程访问服务器将无法成功。一旦出现这种情况,您也可以添加新的防火墙入站规则端口。
详细操作请参考:Windows云服务器怎样关闭防火墙、添加例外端口?。
默认使用的是3389端口,如果您使用的是其他端口,可参考3389端口添加防火墙入站规则。
完成上述操作后,再次重试远程连接云服务器。
检查远程桌面连接设置
修改Windows云服务器的远程桌面连接设置:勾选“允许远程连接到此计算机”。具体操作如下:
- 登录云服务器。
- 打开左下角的“开始”菜单,右键单击“计算机”,并选择“属性”。
- 在左侧导航栏,选择“远程设置”。
- 选择“远程”页签,并在“远程桌面”栏,选择“允许远程连接到此计算机”。
图5 远程设置
- 单击“确定”。
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