更新时间:2024-11-29 GMT+08:00

ALM-45425 ClickHouse服务不可用

告警解释

告警模块按60秒周期检测ClickHouseServer实例状态,当检测到ClickHouseServer某个分片的所有实例异常时,系统产生此告警。

当系统检测到该分片的任一ClickHouseServer实例恢复正常,且告警处理完成时,告警恢复。

告警属性

告警ID

告警级别

告警类型

业务类型

是否可自动清除

45425

紧急

业务质量告警

ClickHouse

告警参数

类别

参数名称

参数含义

定位信息

来源

产生告警的集群或系统名称

服务名

产生告警的服务名称

角色名

产生告警的角色名称

主机名

产生告警的主机名

对系统的影响

ClickHouse服务异常,无法通过FusionInsight Manager对ClickHouse进行集群操作,无法使用ClickHouse服务功能。

可能原因

  • ZooKeeper服务不可用。
  • ClickHouse故障实例节点其组件配置目录下的metrika.xml配置信息和ZooKeeper中对应ClickHouse实例配置不一致。

处理步骤

ZooKeeper服务不可用

  1. 登录FusionInsight Manager,选择“运维 > 告警 > 告警”,在告警列表中,查看是否有“ALM-13000 ZooKeeper服务不可用”告警产生。

    • 是,执行2
    • 否,执行3

  2. 参考“ALM-13000 ZooKeeper服务不可用”告警帮助指导处理该告警。在告警列表中,查看“ALM-45425 ClickHouse服务不可用”告警是否清除。

    • 是,操作结束。
    • 否,执行3

检查ClickHouse实例metrika.xml配置是否正常

  1. 登录FusionInsight Manager,选择“集群 > 服务 > ClickHouse > 实例”,根据告警信息查看是否存在状态异常的ClickHouse实例。

    • 是,执行4
    • 否,执行11

  2. 登录ClickHouse服务异常的实例主机节点,并通过ping其他正常ClickHouse实例节点IP的方式进行网络是否互通验证。

    • 是,执行5
    • 否,联系网络管理员修复网络。

  1. 以客户端安装用户,登录客户端的节点,执行如下命令:

    cd {客户端安装路径}

    source bigdata_env

    • 集群已启用Kerberos认证(安全模式):

      kinit 组件业务用户

      clickhouse client --host 上报告警的ClickHouseServer实例IP --port 9440 --secure

    • 集群未启用Kerberos认证(普通模式):

      clickhouse client --host 上报告警的ClickHouseServer实例IP --user 用户名 --password --port 9000

    查询macros.id对应的值:

    select substitution from system.macros where macro='id';

  2. 登录ZooKeeper客户端所在主机节点,执行以下命令登录ZooKeeper客户端工具。

    切换到客户端安装目录。

    例如:cd /opt/client

    执行以下命令配置环境变量。

    source bigdata_env

    执行以下命令进行用户认证。(普通模式跳过此步骤)

    kinit 组件业务用户

    执行以下命令登录客户端工具。

    zkCli.sh -server ZooKeeper角色实例所在节点业务IP: clientPort

  3. 使用如下命令检查ClickHouse集群拓扑信息是否能正常获取到。

    get /clickhouse/config/5中的macros.id对应的值/metrika.xml

    • 是,执行8
    • 否,不能正常获取则执行11

  1. 登录ClickHouse服务异常的实例主机节点,进入当前ClickHouse实例配置目录。

    cd ${BIGDATA_HOME}/FusionInsight_ClickHouse_版本号/x_x_ClickHouseServer/etc

    cat metrika.xml

  2. 检查7中获取的ZooKeeper上的集群拓扑信息是否与8中组件配置目录下的metrika.xml是否一致。

    • 是,如果确认告警还未恢复则执行11
    • 否,执行10

  3. 在FusionInsight Manager首页,选择“集群 > 服务 > ClickHouse > 更多 > 同步配置”,等待五分钟,查看服务状态是否良好,告警是否恢复。

    • 是,处理完毕。
    • 否,执行11

收集故障信息

  1. 在FusionInsight Manager界面,选择“运维 > 日志 > 下载”。
  2. 在“服务”中勾选待操作集群的“ClickHouse”。
  3. 在“主机”中选择对应的主机。
  4. 单击右上角的时间编辑按钮,设置日志收集的“开始时间”和“结束时间”分别为告警产生时间的前后1小时,单击“下载”。
  5. 请联系运维人员,并发送已收集的故障日志信息。

告警清除

此告警修复后,系统会自动清除此告警,无需手工清除。

参考信息

不涉及。