更新时间:2024-11-29 GMT+08:00

ALM-45293 Ranger用户同步异常

告警解释

系统每5分钟周期性检测UserSync进程的用户同步情况,当存在同步异常时产生该告警。当用户同步正常时,告警恢复。

告警属性

告警ID

告警级别

告警类型

业务类型

是否可自动清除

45293

重要

业务质量告警

Ranger

告警变更

变更类型

变更版本

变更描述

变更原因

新增

3.3.1

首次增加

首次增加

告警参数

类别

参数名称

参数含义

定位信息

来源

产生告警的集群名称。

服务名

产生告警的服务名称。

角色名

产生告警的角色名称。

主机名

产生告警的主机名。

附加信息

Trigger Condition

Ranger同步用户时存在异常。

对系统的影响

未同步的用户无法登录Ranager原生页面,无法通过Ranger为未同步的用户设置权限策略,可能导致未同步用户无法访问被Ranger权限控制的服务。

可能原因

RangerAdmin实例状态异常。

UserSync实例状态异常。

Ldap服务异常。

处理步骤

UserSync状态异常。

  1. 在FusionInsight Manager首页,选择“运维 > 告警 > 告警 > ALM-45293 Ranger用户同步异常”,检查该告警的“定位信息”,查看告警上报的实例主机名。
  2. 在FusionInsight Manager首页,选择“集群 > 服务 > Ranger > 实例”,选择上报告警实例主机名对应的UserSync实例,查看其状态是否异常。

    • 是,执行3
    • 否,执行5

  3. 在FusionInsight Manager首页,选择“集群 > 服务 > Ranger > 实例 > UserSync”,单击“更多”,选择“重启实例”,或重启Ranger服务。
  4. 等待5-10分钟后,观察界面告警是否清除。

    • 是,处理完毕。
    • 否,执行5

RangerAdmin状态异常。

  1. 在FusionInsight Manager首页,选择“运维 > 告警 > 告警”,查看是否存在“ALM-45276 RangerAdmin状态异常”的告警。

    • 是,执行6
    • 否,执行8

  1. 参考“ALM-45276 RangerAdmin状态异常”告警的处理步骤进行处理。
  2. 等待5-10分钟后,观察界面告警是否清除。

    • 是,处理完毕。
    • 否,执行8

Ldap服务异常。

  1. 在FusionInsight Manager首页,选择“运维 > 告警 > 告警”,查看是否存在“ALM-25000 LdapServer服务不可用”的告警。

    • 是,执行9
    • 否,执行11

  1. 参考“ALM-25000 LdapServer服务不可用”告警的处理步骤进行处理。
  2. 等待5-10分钟后,观察界面告警是否清除。

    • 是,处理完毕。
    • 否,执行11

收集故障信息。

  1. 在FusionInsight Manager界面,选择“运维 > 日志 > 下载”。
  2. 在“服务”框中勾选待操作集群的“Ranger”。
  3. 单击右上角的时间编辑按钮,设置日志收集的“开始时间”和“结束时间”分别为告警产生时间的前后10分钟,单击“下载”。
  4. 请联系运维人员,并发送已收集的故障日志信息。

告警清除

此告警修复后,系统会自动清除此告警,无需手工清除。

参考信息

不涉及。