更新时间:2024-11-29 GMT+08:00

ALM-43850 KMS服务不可用

告警解释

系统每60秒周期性检测KMS的服务状态,当检测到KMS服务不可用,此时产生该告警。

KMS服务恢复时,告警清除。

告警属性

告警ID

告警级别

告警类型

业务类型

是否可自动清除

43850

紧急

业务质量告警

KMS

告警参数

类别

参数名称

参数含义

定位信息

来源

产生告警的集群名称。

服务名

产生告警的服务名称。

角色名

产生告警的角色名称。

主机名

产生告警的主机名。

对系统的影响

KMS无法提供加密密钥管理服务,如果用户获取不到密钥会导致数据无法加解密,使用KMS加解密的业务运行失败。

可能原因

  • ZooKeeper服务故障。
  • KMSWebServer实例故障。

处理步骤

检查KMSWebServer状态。

  1. 在FusionInsight Manager界面,选择“集群 > 待操作集群的名称 > 服务 > ZooKeeper”,在FusionInsight Manager界面查看Zookeeper服务的运行状态是否为良好。

    • 是,执行3
    • 否,执行2

  2. 参考“ALM-13000 ZooKeeper服务不可用”,对Zookeeper服务状态异常进行处理,然后查看ZooKeeper运行状态是否恢复为“良好”。

    • 是,执行3
    • 否,执行5

  3. 在FusionInsight Manager界面,选择“集群 > 待操作集群的名称 > 服务 > KMS”,在“概览”中,检查KMSWebServer角色是否有运行状态为“良好”的节点。

    • 是,执行4
    • 否,执行5

  4. 选择“运维 > 告警 > 告警”,在“告警”界面,查看本告警是否恢复。

    • 是,处理完毕。
    • 否,执行5

收集故障信息。

  1. 在FusionInsight Manager界面,选择“运维 > 日志 > 下载”。
  2. 在“服务”中勾选待操作集群的如下服务。

    • ZooKeeper
    • KrbServer

  3. 单击“确定”。
  4. 单击右上角的设置日志收集的“开始时间”和“结束时间”分别为告警产生时间的前后10分钟,单击“下载”。
  5. 请联系运维人员,并发送已收集的故障日志信息。

告警清除

此告警修复后,系统会自动清除此告警,无需手工清除。

参考信息

不涉及。