更新时间:2024-11-29 GMT+08:00

ALM-43619 GraphBase HA证书文件失效

告警解释

GraphBase首次或者每天01:00:00开始健康检查时,检查当前系统中的HA证书文件是否失效(证书是否存在,证书格式是否正确),如果证书文件失效,产生该告警。

告警属性

告警ID

告警级别

告警类型

业务类型

是否可自动清除

43619

重要

业务质量告警

GraphBase

告警参数

类别

告警参数

参数含义

定位信息

来源

产生告警的集群名称。

服务名

产生告警的服务名称。

角色名

产生告警的角色名称。

主机名

产生告警的主机名。

对系统的影响

HA根证书文件或HA用户证书文件已经失效,功能受限,无法正常使用。

可能原因

HA根证书文件失效或HA用户证书文件失效。

处理步骤

查看告警信息。

  1. 登录FusionInsight Manager首页,选择“运维 > 告警 > 告警 > ALM-43619 GraphBase HA证书文件失效”。查看定位信息中的主机名和附加信息中的文件名,使用PuTTY工具以omm用户登录告警所在节点主机。

    • 告警附加信息中显示的文件名为“root-ca.crt”,执行2
    • 告警附加信息中显示的文件名为“server.crt”,执行10

检查系统中HA根证书文件是否有效

  1. 执行命令cd ${BIGDATA_HOME}/FusionInsight_GraphBase_*/install/FusionInsight-GraphBase-*/miner/ha/local/cert,进入HA证书目录
  2. 执行命令ls -l,查看“root-ca.crt”文件是否存在。

    • 是,执行4
    • 否,执行16

  3. 执行命令openssl x509 -in root-ca.crt -text -noout,查看是否正常显示

    • 是,执行16
    • 否,执行5

  4. 在FusionInsight Manager的告警列表中,查看是否有“ALM-12054 证书文件失效”告警产生。

    • 是,执行6
    • 否,执行7

  5. 参考“ALM-12054 证书文件失效”的处理步骤处理该告警。
  6. 执行命令cp ${NODE_AGENT_HOME}/security/cert/subcert/certFile/ca.crt root-ca.crtcp ${NODE_AGENT_HOME}/security/cert/subcert/certFile/ca.key root-ca.pem,重新拷贝HA根证书,执行rm ${BIGDATA_HOME}/FusionInsight_GraphBase_*/install/FusionInsight-GraphBase-*/miner/bin/CHECK_FLAG,等待1分钟,观察附加信息相同的此告警是否被清除。

    • 是,执行8
    • 否,执行16

  7. omm用户登录在另一个LoadBalancer实例所在节点,重复执行2~7
  8. 查看系统在定时检查时是否会再次产生附加信息相同的此告警。

    • 是,执行16
    • 否,处理完毕。

检查系统中HA用户证书文件是否有效

  1. 执行命令cd ${BIGDATA_HOME}/FusionInsight_GraphBase_*/install/FusionInsight-GraphBase-*/miner/ha/local/cert,进入HA证书目录
  2. 执行命令ls -l,查看server.crt文件是否存在。

    • 是,执行12
    • 否,执行13

  3. 执行命令openssl x509 -in server.crt -text -noout,查看是否正常显示

    • 是,执行16
    • 否,执行13

  4. 执行命令cd ${BIGDATA_HOME}/FusionInsight_GraphBase_*/install/FusionInsight-GraphBase-*/miner/bin,进入miner脚本目录。
  5. 执行命令sh miner-ha-re-gencert.sh,重新生成HA证书,等待1分钟,观察附加信息相同的此告警是否被清除。

    • 是,执行15
    • 否,执行16

  6. 查看系统在定时检查时是否会再次产生附加信息相同的此告警。

    • 是,执行16
    • 否,处理完毕。

收集故障信息。

  1. 在FusionInsight Manager界面,选择“运维 > 日志 > 下载”。
  2. 在“服务”中勾选待操作集群的GraphBase。
  3. 单击右上角的设置日志收集的“开始时间”和“结束时间”分别为告警产生时间的前后10分钟,单击“下载”。
  4. 请联系技术支持人员,并发送已收集的故障日志信息。

告警清除

此告警修复后,系统会自动清除此告警,无需手工清除。

参考信息

不涉及。