更新时间:2024-11-29 GMT+08:00
ALM-27004 DBService主备数据不同步
告警解释
DBService主备数据不同步,每10秒检查一次主备数据同步状态,如果连续6次查不到同步状态,或者同步状态不正常,产生告警。
当同步状态正常,告警恢复。
告警属性
告警ID |
告警级别 |
告警类型 |
业务类型 |
是否可自动清除 |
---|---|---|---|---|
27004 |
紧急 |
业务质量告警 |
FusionInsight Manager |
是 |
告警参数
类别 |
参数名称 |
参数含义 |
---|---|---|
定位信息 |
来源 |
产生告警的集群名称。 |
服务名 |
产生告警的服务名称。 |
|
角色名 |
产生告警的角色名称。 |
|
主机名 |
产生告警的主机名。 |
|
附加信息 |
本端DBService HA名 |
本端DBService HA名称。 |
对端DBService HA名 |
对端DBService HA名称。 |
|
主备DBService 同步率 |
主备DBService节点同步率。 |
对系统的影响
主备DBServer数据不同步,如果此时主实例异常,则会出现数据丢失或者数据异常的情况。
可能原因
- 主备节点网络不稳定。
- 备DBService异常。
- 备节点磁盘空间满。
- 主DBService节点GaussDB进程CPU使用率高(需要通过日志定位该问题)。
处理步骤
检查主备节点网络是否正常。
- 在FusionInsight Manager页面,选择“集群 > 服务 > DBService > 实例”,查看备DBServer实例的业务IP地址。
- 以root用户登录主DBService节点。
- 执行ping 备DBService心跳IP地址命令检查备DBService节点是否可达。
- 联系网络管理员查看是否为网络故障。
- 修复网络故障,查看告警列表中,该告警是否已清除。
- 是,处理完毕。
- 否,执行6。
检查备DBService状态是否正常
- 以root用户登录备DBService节点。
- 执行su - omm命令切换到omm用户。
- 进入“${DBSERVER_HOME}/sbin”目录,然后执行命令 ./status-dbserver.sh 检查备DBService的gaussDB资源状态是否正常,查看回显中,“ResName”为“gaussDB”的一行,是否显示如下信息:
例如:
10_10_10_231 gaussDB Standby_normal Normal Active_standby
检查备节点磁盘是否已满。
- 以root用户登录备DBService节点。
- 执行命令su - omm切换到omm用户。
- 进入“${DBSERVER_HOME}”目录,执行以下命令获取DBservice的数据目录。
cd ${DBSERVER_HOME}
source .dbservice_profile
echo ${DBSERVICE_DATA_DIR}
- 执行df -h命令,查看系统磁盘分区的使用信息。
- 查看DBservice数据目录空间是否已满。
- 对节点磁盘进行扩容。
- 磁盘扩容后,等待2分钟检查告警是否清除。
- 是,操作结束。
- 否,执行16。
收集故障信息。
告警清除
此告警修复后,系统会自动清除此告警,无需手工清除。
参考信息
不涉及。
父主题: 告警参考