ALM-25004 LdapServer数据同步异常
告警解释
系统按30秒周期性检测LdapServer数据,如果连续12次检测,Manager的主备LdapServer的数据内容都不一致,产生该告警,当两者的数据一致时,对应告警恢复。
系统按30秒周期性检测LdapServer数据,如果连续12次检测,集群中的LdapServer的数据与Manager的LdapServer数据都不一致,产生该告警,当两者的数据一致时,对应告警恢复。
告警属性
告警ID |
告警级别 |
告警类型 |
业务类型 |
是否可自动清除 |
---|---|---|---|---|
25004 |
紧急 |
业务质量告警 |
FusionInsight Manager |
是 |
告警参数
类别 |
参数名称 |
参数含义 |
---|---|---|
定位信息 |
来源 |
产生告警的集群名称。 |
服务名 |
产生告警的服务名称。 |
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角色名 |
产生告警的角色名称。 |
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主机名 |
产生告警的主机节点信息。 |
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附加信息 |
详细信息 |
产生告警的详细信息。 |
对系统的影响
LdapServer数据不一致时,有可能是Manager上的LdapServer数据损坏,也有可能是集群上的LdapServer数据损坏,此时数据损坏的LdapServer进程将无法对外提供服务,影响Manager和集群的认证功能。
可能原因
- LdapServer进程所在的节点网络故障。
- LdapServer进程异常。
- OS重启导致的LdapServer数据损坏。
处理步骤
检查LdapServer所在的节点网络是否故障。
- 在FusionInsight Manager界面,选择“运维 > 告警 > 告警”。记录该告警定位信息中的“主机名”的IP地址为IP1(若出现多个告警,则分别记录其中的IP地址为IP1、IP2、IP3等)。
- 联系运维人员,登录IP1节点,在这个节点上使用ping命令检查该节点与主OMS节点的管理平面IP是否可达。
- 联系网络管理员恢复网络,然后查看“LdapServer数据同步异常”告警是否恢复。
- 是,处理完毕。
- 否,执行4。
检查LdapServer进程是否正常。
- 在FusionInsight Manager的“告警”页面,查看是否有LdapServer的“OLdap资源异常”告警产生。
- 按照“ALM-12004 OLdap资源异常”提供的步骤处理该告警。
- 在告警列表中查看“LdapServer数据同步异常”告警是否清除。
- 是,处理完毕。
- 否,执行7。
- 在FusionInsight Manager的“告警”页面,查看是否有LdapServer的“进程故障”告警产生。
- 按照“ALM-12007 进程故障”提供的步骤处理该告警。
- 在告警列表中查看“LdapServer数据同步异常”告警是否清除。
- 是,处理完毕。
- 否,执行10。
检查是否存在因为OS重启导致LdapServer数据损坏。
- 在FusionInsight Manager界面,选择“运维 > 告警 > 告警”。记录该告警定位信息中的“主机名”的IP地址为IP1(若出现多个告警,则分别记录其中的IP地址为IP1,IP2,IP3等)。选择“集群 > 待操作集群的名称 > 服务 > LdapServer > 配置”,记录LdapServer的端口号PORT(若告警定位信息中的IP地址为备管理节点IP地址,选择“系统 > OMS > oldap > 修改配置”,记录LdapServer服务侦听端口号)。
- 以omm用户登录IP1节点。
- 执行以下命令,观察查询出来的内容是否提示有error错误信息。
ldapsearch -H ldaps://IP1:PORT -LLL -x -D cn=root,dc=hadoop,dc=com -W -b ou=Peoples,dc=hadoop,dc=com
执行命令后需输入LDAP管理员密码,请联系MRS集群管理员获取。
- 使用告警出现日期之前的备份文件进行LdapServer恢复和OMS恢复。
必须使用同一时间点的OMS和LdapServer备份数据进行恢复,否则可能造成业务和操作失败。当业务正常时需要恢复数据,建议手动备份最新管理数据后,再执行恢复数据操作,否则会丢失从备份时刻到恢复时刻之间的Manager数据。
- 在告警列表中查看“LdapServer数据同步异常”告警是否清除。
- 是,处理完毕。
- 否,执行15。
收集故障信息。
告警清除
此告警修复后,系统会自动清除此告警,无需手工清除。
参考信息
不涉及。