更新时间:2024-11-29 GMT+08:00
ALM-12039 OMS数据库主备不同步
告警解释
OMS数据库主备不同步,系统每10秒检查一次主备数据同步状态,如果连续30次查不到同步状态,或者同步状态异常,产生告警。
当主备数据同步状态正常,告警恢复。
告警属性
告警ID |
告警级别 |
告警类型 |
业务类型 |
是否可自动清除 |
---|---|---|---|---|
12039 |
重要 |
业务质量告警 |
FusionInsight Manager |
是 |
告警参数
类别 |
参数名称 |
参数含义 |
---|---|---|
定位信息 |
来源 |
产生告警的集群或系统名称。 |
服务名 |
产生告警的服务名称。 |
|
角色名 |
产生告警的角色名称。 |
|
主机名 |
产生告警的主机名。 |
|
附加信息 |
本端GaussDB HA名 |
本地GaussDB HA IP地址。 |
对端GaussDB HA名 |
对端GaussDB HA IP地址。 |
|
主备GaussDB 同步率 |
同步百分比。 |
对系统的影响
OMS数据库主备不同步会导致主数据库的数据无法正常同步至备数据库,在告警上报时间段若主实例异常可能会导致用户业务数据丢失或者Manager页面数据显示异常。
可能原因
- 主备节点网络不稳定。
- 备OMS数据库异常。
- 备节点磁盘空间满。
处理步骤
检查主备节点网络是否正常。
- 在FusionInsight Manager界面上选择“运维 > 告警 > 告警”,在告警列表中,单击此告警所在行的,查看该告警的OMS数据库备节点IP地址。
- 以root用户登录主OMS数据库节点。
- 执行ping 备OMS数据库心跳IP地址命令检查备OMS数据库节点是否可达。
- 联系网络管理员查看是否为网络故障。
- 修复网络故障,然后查看告警列表中,该告警是否已清除。
- 是,处理完毕。
- 否,执行6。
检查备OMS数据库状态是否正常。
- 以root用户登录备OMS数据库节点。
- 执行su - omm命令切换到omm用户。
- 进入“${BIGDATA_HOME}/om-server/om/sbin/”目录,然后执行./status-oms.sh命令检查备OMS数据库资源状态是否正常,查看回显中,“ResName”为“gaussDB”的一行,是否显示如下信息:
例如:
10_10_10_231 gaussDB Standby_normal Normal Active_standby
检查备节点磁盘是否已满。
- 以root用户登录备OMS数据库节点。
- 执行su - omm命令切换到omm用户。
- 执行echo ${BIGDATA_DATA_HOME}/dbdata_om命令获取OMS数据库的数据目录。
- 执行df -h命令,查看系统磁盘分区的使用信息。
- 查看OMS数据库数据目录挂载磁盘是否已满。
- 进行磁盘扩容。
- 磁盘扩容后,等待2分钟检查告警是否清除。
- 是,操作结束。
- 否,执行16。
收集故障信息。
告警清除
此告警修复后,系统会自动清除此告警,无需手工清除。
参考信息
不涉及。
父主题: 告警参考