更新时间:2025-08-07 GMT+08:00
配置指标告警规则时统计周期选择1分钟,没有产生告警数据
问题描述
配置指标告警规则时统计周期选择1分钟,没有产生告警数据。
原因分析
指标告警规则的统计周期选择1分钟时,如果指标上报有延迟,导致可能还没有产生告警数据。
解决方法
在创建指标告警规则时,设置“统计周期”和“检测规则”要根据监控的指标采集周期和指标采集时延、以及业务模型去选择对应的值。
- 统计周期:在创建指标告警规则时,首先需要确认指标延迟时间,即最新的指标数据时间与当前时间的时间差,然后确定统计周期范围。
- 如果最新指标数据时间点为当前时间,则说明指标数据无延迟,那么统计周期可以选择1分钟及以上。
- 如果最新指标数据时间点小与当前时间1分钟以上,5分钟以内,则统计周期可以选择5分钟及以上。
- 如果最新指标数据时间点小与当前时间5分钟以上,15分钟以内,则统计周期可以选择15分钟及以上。
- 如果最新指标数据时间点时延大于15分钟,请联系AOM的相关工程师处理。
在创建指标告警规则时,选择上报的指标后,在指标图表中的X轴中可查看最新指标数据时间点。如果指标采集周期为1分钟,则建议按照上述原则配置统计周期;如果指标采集周期不为1分钟,则在选择统计周期时应先观察指标延迟时间,统计周期的最优选项值建议为指标延迟时间+指标采集周期时间。
- 检测规则:在创建指标告警规则时,需要用户根据自身的监控需求,先判断统计周期内采集到的所有指标的统计方式(平均值、最小值、最大值、总计、样本个数)、判断条件(≥、≤、>、<)和阈值,然后配置对应的检测规则。
如果用户对指标断点或者指标时延有监控要求,可以通过开启指标告警规则中的“高级设置”的“无数据处理”开关,设置在监控周期内无数据情况时系统的处理方式。
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