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更新时间:2024-03-15 GMT+08:00

如何处理迁移Agent提示“AK,SK鉴权失败,请保证系统时间与标准时间一致,并检查AK,SK”?

问题描述

在迁移Agent中输入AK/SK以后,AK/SK校验失败。

  • Windows系统提示用户:"AK/SK authentication failed. Ensure that the system time is consistent with the standard time and the AK and SK are correct."

  • Linux系统提示用户:“AK/SK authentication failed. Ensure that the system time is consistent with the standard time and the AK and SK are correct.”

问题原因

出现该问题可能的原因有:

  • AK,SK输入错误。
  • 源端服务器时间与标准时间不匹配。
  • 源端服务器时区设置不对。
  • AK,SK被删除或停用。
  • 当前迁移账号没有开通编程访问方式。

处理方法

  • AK,SK输入错误

    请您检查输入的AK/SK是否正确,特别是复制的时候有没有复制空格或者遗漏字符等。重新输入AK/SK进行校验。

  • 源端服务器时间与标准时间不匹配

    请您检查源端服务器的系统时间与其所在时区的标准时间是否一致,若不一致会导致迁移Agent中AK/SK校验失败。

    此时请您将源端服务器的系统时间与其所在时区的标准时间调整一致再重新输入AK/SK进行校验。

    若源端服务器有业务依赖于服务器时间,请确认是否能够修改该时间,避免对业务造成影响。

  • 源端服务器时区设置不对

    修改源端服务器时区使时间+时区能转化为标准UTC时间,修改方式请参见《弹性云服务器用户指南》的“更改时区章节”。重新输入AK/SK进行校验。

  • AK,SK被删除或停用
    请前往“我的凭证 > 访问密钥”中查看使用的AK/SK是否在列表中。
    • 如果不在列表中,可以更换或创建一个新的AK/SK。
    • 如果在列表中,检查是否被停用,如果被停用请重新启用。
  • 当前迁移账号没有开通编程访问方式
    1. 登录管理控制台。
    2. 单击页面右上角的用户名,并选择“统一身份认证”,进入“统一身份认证服务”界面。
    3. 在左侧导航树,选择“用户”,单击迁移账号的用户名,进入“基本信息”页面。
    4. 在迁移账号基本信息页面,查看访问方式是否包含“编程访问”。

    5. 单击按钮,勾选“编程访问”,单击“确定”按钮。