更新时间:2024-04-18 GMT+08:00
密钥对鉴权方式的Windows云服务器无法获取密码怎么办?
问题描述
密钥对鉴权方式的Windows云服务器,使用私钥文件获取登录密码失败。
可能原因
出现获取密码失败一般原因是Cloudbase-init注入密码失败。 Cloudbase-init注入密码失败原因有:
- 网络原因导致云服务器器无法连接到Cloudbase-init服务器。
- 镜像上Cloudbase-init没有获取密码相关配置。
- 云服务器上其他问题导致Cloudbase-init注入密码失败。
处理方法
使用Cloudbase-init特性的弹性云服务器时,如果登录失败,可以从以下几个原因进行排查:
- 检查创建云服务器的镜像是否正常配置了Cloudbase-init。
- 不安装Cloudbase-Init工具,将无法对云服务器进行自定义配置,只能使用镜像原有密码登录云服务器。
- 使用公共镜像创建的云服务器,默认已经安装Cloudbase-Init,不需要执行安装及配置操作。
- 使用外部镜像文件创建的云服务器,请按照指导安装及配置Cloudbase-Init。
详细操作请参考《镜像服务用户指南》“安装并配置Cloudbase-Init工具”。
- 判断登录弹性云服务器时使用的密钥对是否正确。
检查获取密码使用的密钥文件是否为创建云服务器时使用的密钥。
- 弹性云服务器使用的VPC网络DHCP不能禁用。
在管理控制台查看云服务器所在子网是否启用了DHCP。
- 弹性云服务器需绑定弹性公网IP。
- 查看安全组出方向规则,需确保80端口“出方向”和“入方向”均放通。
- 通过查看日志检查原因,Cloudbase-init日志查看步骤如下:
- 将无法获取密钥的弹性云服务器关机后,将系统盘卸载。
- 使用公共镜像创建一个临时Windows云服务器,将6.a中卸载的卷挂载在此云服务器上。
- 登录临时创建的云服务器,打开服务器管理器,选择“文件和存储服务 > 卷 > 磁盘”,单击鼠标右键选择“脱机”状态的磁盘,单击“联机”。
图1 磁盘联机
- 打开新联机的磁盘,查看“/Programe Files/Cloudbase Solution/Cloudbase-Init/log”路径下的“cloudbase-init”文件,通过日志查看原因。
图2 查看cloudbase-init文件
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