文档首页/ 应用运维管理 AOM/ 常见问题(2.0)/ 采集管理/ ICAgent安装成功后,AOM中无法监控到CPU内存使用率等信息
更新时间:2024-04-11 GMT+08:00

ICAgent安装成功后,AOM中无法监控到CPU内存使用率等信息

问题描述

ICAgent安装成功后,AOM无法监控到CPU内存使用率等信息。

原因分析

  • 8149端口未连通。
  • 用户侧节点时间与所在时区当前时间不一致。

解决办法

  1. 以root用户登录安装ICAgent的服务器。
  2. 执行以下命令,检查ICAgent是否可成功上报指标。

    cat /var/ICAgent/oss.icAgent.trace | grep httpsend | grep MONITOR
    • 若回显信息中包含“failed”字样,则说明ICAgent无法成功上报指标 => 执行3
    • 若回显信息中无“failed”字样,则说明ICAgent可成功上报指标 => 执行 4

  3. 查询端口连通性。

    1. 执行以下命令,获取ACCESS的IP地址。
      cat /opt/oss/servicemgr/ICAgent/envs/ICProbeAgent.properties | grep ACCESS_IP
    2. 依次执行以下命令,检查8149端口的连通性。
      curl -k https://ACCESS_IP:8149
      • 若回显信息为“404”,则说明端口连通性正常 => 请联系技术支持工程师。
      • 若回显信息不为“404”,则说明端口未连通 => 请联系网络管理开放端口后,重新安装ICAgent。如果仍未安装成功,请联系技术支持工程师。

  4. 执行以下命令,检查用户侧节点时间。

    date
    • 若查询到的用户侧节点时间和所在时区当前时间一致 => 请联系技术支持工程师。
    • 若查询到的用户侧节点时间和所在时区当前时间不一致 => 执行 4

  5. 执行以下命令,重新配置用户侧节点时间。

    date -s 所在时区当前时间(例如12:34:56)