更新时间:2024-03-13 GMT+08:00
ICAgent安装成功后,无法在界面上获取到ICAgent状态
问题描述
ICAgent安装成功后,无法在界面上获取到ICAgent状态。
原因分析
用户侧使用虚拟网卡,想要获取到ICAgent状态信息需要修改下相关脚本规避。
解决办法
- 以root用户登录已安装ICAgent的CCE集群的某个主机服务器。
- 执行以下命令,查看正在使用的hostIP地址,如图1所示。
netstat -nap | grep establish -i
- 执行以下命令,查看IP地址对应的网卡,如图2所示。
ifconfig | grep IP地址 -B1
- 进入/sys/devices/virtual/net/目录下,查看是否存在该网卡的名称。
- 存在该网卡名称,则表示该网卡为虚拟网卡 => 5
- 不存在该网卡名称,则表示该网卡不为虚拟网卡 => 请联系技术支持工程师处理。
- 执行以下操作,修改ICAgent启动脚本。
- 根据ICAgent版本,选择合适的命令,打开icagent_mgr.sh文件。
vi /opt/oss/servicemgr/ICAgent/bin/manual/icagent_mgr.sh
或
vi /var/opt/oss/servicemgr/ICAgent/bin/manual/icagent_mgr.sh
- 修改脚本文件。
在文件中增加一行:export IC_NET_CARD="虚拟网卡名称",如图3所示。
- 根据ICAgent版本,选择合适的命令,打开icagent_mgr.sh文件。
- 根据ICAgent版本,选择合适的命令,重启ICAgent。
sh /opt/oss/servicemgr/ICAgent/bin/manual/mstop.sh sh /opt/oss/servicemgr/ICAgent/bin/manual/mstart.sh
或
sh /opt/oss/servicemgr/ICAgent/bin/manual/mstop.sh sh /var/opt/oss/servicemgr/ICAgent/bin/manual/mstop.sh
- 登录AOM控制台的“采集管理”界面,查看ICAgent状态是否可以显示。
- ICAgent状态正常显示 => 结束。
- ICAgent状态仍然不显示 => 请联系技术支持工程师处理。
父主题: 采集管理