更新时间:2022-12-29 GMT+08:00

如何排查500/502/504错误?

业务接入WAF防护之后,访问网站如果出现500 Internal Server Error,502 Bad Gateway,504 Gateway Timeout等错误,请参考以下方法排查错误。

现象一

完成WAF配置之后正常,但是一段时间后就报502,或者大概率出现502。
  • 可能原因

    防火墙、后端服务器安全防护软件、业务限速策略拦截。

  • 解决方法

    将WAF的回源IP网段添加到防火墙(硬件或软件)、安全防护软件、业务限速模块的白名单。

现象二

完成WAF配置之后,访问页面返回502/500,或者大概率出现502/500(当后端配置了多个服务器的情况)。
  • 可能原因

    源站配置错误。

  • 解决方法

    “域名配置”列表中找到相应的域名记录,单击域名名称,进入域名基本信息页面,在“服务器信息”栏中,确认源站协议、IP、端口等信息是否正确。

    可在浏览器访问源站IP地址来检查后端业务端口是否打开。

现象三

完成WAF配置之后,HTTPS业务大概率返回502,而直接通过IP访问源站正常。
  • 可能原因

    HTTPS采用不安全的协议版本。

  • 解决方法
    SSL低版本的协议存在严重的安全隐患,Web应用防火墙支持TLS1.2及以上版本的协议。如果您的业务服务器的SSL版本较低,接入WAF之后则会出现502错误,需要您升级解决。您可以在通过“https://www.ssllabs.com/ssltest/index.html”检查网站服务的SSL版本信息:
    • 如果你的Web服务器是Windows 2008以前的版本,SSL协议不支持TLS1.2及以上。您需要将服务器版本升级到Windows 2008以上(或Linux较新版本的操作系统),并在IIS等服务中开启TLS1.2。
    • 如果您的Web服务是其他系统,请确认SSL协议是否是TLS1.2或以上。

现象四

完成WAF配置之后,业务正常。但业务量增加时,502/504比例增加。直接访问源站也有一定概率出现502/504的返回码。
  • 可能原因

    后端服务器性能问题。

  • 解决方法
    1. 优化服务器的相关配置,包括TCP网络参数的优化配置,ulimit相关参数设置等。
    2. 对后端ECS扩容来支撑业务增长,WAF支持配置多个后端服务器。
    3. 如果业务为HTTPS,可考虑在WAF设置HTTPS转发,回源走HTTP协议,降低后端服务器的计算压力。