ALM-45652 Flink Service Unavailable
This section applies to MRS 3.3.0 or later.
Alarm Description
The alarm module checks the Flink status every 60 seconds. This alarm is generated when the Flink service is unavailable. This alarm is cleared when the Flink service recovers.
Alarm Attributes
Alarm ID |
Alarm Severity |
Auto Cleared |
---|---|---|
45652 |
Critical |
Yes |
Alarm Parameters
Parameter |
Description |
---|---|
Source |
Specifies the cluster for which the alarm is generated. |
ServiceName |
Specifies the service for which the alarm is generated. |
RoleName |
Specifies the role for which the alarm is generated. |
HostName |
Specifies the job for which the alarm is generated. |
Impact on the System
Flink jobs cannot be submitted with FlinkServer and the Flink client.
Possible Causes
The ZooKeeper, HDFS, Yarn, KrbServer, or DBService service on which Flink depends is unavailable.
Handling Procedure
Check the alarm cause of Flink Service Unavailable.
If the alarm cause is ZooKeeper abnormality, check the ZooKeeper service on which Flink depends.
- Log in to FusionInsight Manager and choose O&M > Alarm > Alarms.
- In the alarm list, check whether "ALM-13000 ZooKeeper Service Unavailable" exists.
- Handle the alarm by referring to ALM-13000 ZooKeeper Service Unavailable.
- After the alarm is cleared, wait a few minutes and check whether the alarm is cleared.
- If yes, no further action is required.
- If no, go to Step 5.
If the alarm cause is HDFS abnormality, check the HDFS service on which Flink depends.
- On FusionInsight Manager, choose O&M > Alarm > Alarms.
- In the alarm list, check whether "ALM-14000 HDFS Service Unavailable" exists.
- Handle the alarm by referring to ALM-14000 HDFS Service Unavailable.
- After the alarm is cleared, wait a few minutes and check whether the alarm is cleared.
- If yes, no further action is required.
- If no, go to Step 9.
If the alarm cause is YARN abnormality, check the YARN service on which Flink depends.
- On FusionInsight Manager, choose O&M > Alarm > Alarms.
- In the alarm list, check whether "ALM-18000 Yarn Service Unavailable" exists.
- Handle the alarm by referring to ALM-18000 Yarn Service Unavailable.
- After the alarm is cleared, wait a few minutes and check whether the alarm is cleared.
- If yes, no further action is required.
- If no, go to Step 13.
Collect fault information.
- On FusionInsight Manager, choose O&M. In the navigation pane on the left, choose Log > Download.
- Expand the Service drop-down list, and select Flink for the target cluster.
- Click
in the upper right corner, and set Start Date and End Date for log collection to 30 minutes ahead of and after the alarm generation time respectively. Then, click Download.
- Send the collected fault logs to O&M personnel for help.
Alarm Clearance
This alarm is automatically cleared after the fault is rectified.
Related Information
None.
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