ALM-24003 Flume Client Connection Interrupted
Alarm Description
The alarm module monitors the port connection status on the Flume server. This alarm is generated if the Flume server fails to receive a connection message from the Flume client in three consecutive minutes.
This alarm is cleared after the Flume server receives a connection message from the Flume client.
Alarm Attributes
Alarm ID |
Alarm Severity |
Auto Cleared |
---|---|---|
24003 |
Major |
Yes |
Alarm Parameters
Parameter |
Description |
---|---|
Source |
Specifies the cluster for which the alarm was generated. |
Client IP Address |
Specifies the IP address of the Flume client. |
Client Name |
Specifies the agent name of the Flume client. |
Sink Name |
Specifies the sink name of Flume Agent. |
Impact on the System
The communication between the Flume client and the server fails. The Flume client cannot send data to the Flume server.
Possible Causes
- The network connection between the Flume client and the server is faulty.
- The Flume client's process is abnormal.
- The Flume client is incorrectly configured.
Handling Procedure
Check the network connection between the Flume client and the server.
- Log in to the host whose IP address is specified by Flume ClientIP in the alarm information as user root.
- Run the ping Flume server IP address command to check whether the network connection between the Flume client and the server is normal.
Check whether the Flume client's process is normal.
- Log in to the host whose IP address is specified by Flume ClientIP in the alarm information as user root.
- Run the ps -ef|grep flume |grep client command to check whether the Flume client process exists.
Check the Flume client configuration.
- Log in to the host whose IP address is specified by Flume ClientIP in the alarm information as user root.
- Run the cd Flume client installation directory/fusioninsight-flume-1.9.0/conf/ command to go to Flume's configuration directory.
- Run the cat properties.properties command to query the current configuration file of the Flume client.
- Check whether the properties.properties file is correctly configured according to the configuration description of the Flume agent.
- Modify the properties.properties configuration file.
Check whether the alarm is cleared.
- Check whether the alarm is cleared.
- If yes, no further action is required.
- If no, go to 11.
Collect the fault information.
- On FusionInsight Manager, choose O&M. In the navigation pane on the left, choose Log > Download.
- Expand the Service drop-down list, and select Flume for the target cluster.
- Click the edit icon in the upper right corner, and set Start Date and End Date for log collection to 1 hour ahead of and after the alarm generation time, respectively. Then, click Download.
- Collect logs in the /var/log/Bigdata/flume-client directory on the Flume client using a transmission tool.
- Contact O&M personnel and provide the collected logs.
Alarm Clearance
This alarm is automatically cleared after the fault is rectified.
Related Information
None
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