Help Center > > User Guide> FusionInsight Manager Operation Guide> Alarm Reference (Applicable to MRS 3.x)> ALM-24004 Exception Occurs When Flume Reads Data

ALM-24004 Exception Occurs When Flume Reads Data

Updated at: Mar 25, 2021 GMT+08:00

Description

The alarm module monitors the status of Flume Source. This alarm is generated immediately when the duration in which Source fails to read the data exceeds the threshold.

The default threshold is 0, indicating that the threshold is disabled. You can change the threshold by modifying the properties.properties file. Specifically, modify the NoDatatime parameter of required the source.

The alarm is cleared when Source reads the data and the alarm handling is complete.

Attribute

Alarm ID

Alarm Severity

Automatically Cleared

24004

Major

Yes

Parameters

Name

Meaning

Source

Specifies the cluster for which the alarm is generated.

ServiceName

Specifies the service name for which the alarm is generated.

HostName

Specifies the host name for which the alarm is generated.

AgentName

Specifies the agent name for which the alarm is generated.

ComponentType

Specifies the component type for which the alarm is generated.

ComponentName

Specifies the component name for which the alarm is generated.

Impact on the System

If data is found in the data source and Flume Source continuously fails to read data, the data collection is stopped.

Possible Causes

  • Flume Source is faulty, so data cannot be sent.
  • The network is faulty, so the data cannot be sent.

Procedure

Check whether Flume Source is faulty.

  1. Check whether the type of Flume Source is spooldir.

    • If yes, go to 2.
    • If no, go to 3.

  2. View the spoolDir directory to check whether all files are already transferred.

    • If yes, no further action is required.
    • If no, go to 5.

  3. Check whether the type of Flume Source is Kafka.

    • If yes, go to 4.
    • If no, go to 7.

  4. Check whether the topic data configured by Kafka Source has been used up. .

    • If yes, no further action is required.
    • If no, go to 5.

  5. On the FusionInsight Manager portal, choose Cluster > Name of the desired cluster > Services > Flume > Instance.
  6. Go to the Flume instance page of the faulty node to check whether the indicator Source Speed Metrics in the alarm is 0.

    • If yes, go to 11.
    • If no, no further operation is required.

Check the network connection between the faulty node and the node that corresponds to the Flume Source IP address.

  1. Confirm whether the type of Flume Source is avro.

    • If yes, go to 8.
    • If no, go to 11.

  2. Log in to the faulty node as user root, and run the ping IP address of Flume Source command to check whether the peer host can be pinged successfully.

    • If yes, go to 11.
    • If no, go to 9.

  3. Contact the network administrator to restore the network.
  4. In the alarm list, check whether the alarm is cleared after a period.

    • If yes, no further action is required.
    • If no, go to 11.

Collect fault information.

  1. On the FusionInsight Manager portal, choose O&M > Log > Download.
  2. Select Flume in the required cluster from the Service drop-down list box.
  3. Click in the upper right corner, and set Start Date and End Date for log collection to 1 hour ahead of and after the alarm generation time, respectively. Then, click Download.
  4. Contact the O&M personnel and send the collected fault logs.

Alarm Clearing

After the fault is rectified, the system automatically clears this alarm.

Related Information

None

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