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ALM-12103 Executor Resource Exception

Updated on 2024-09-23 GMT+08:00

Alarm Description

HA checks the Executor resources of Manager every 30 seconds. This alarm is generated when HA detects that the Executor resources are abnormal for two consecutive times.

This alarm is cleared when the Executor resources are normal.

Resource Type of Executor is Single-active. Active/standby will be triggered upon resource exceptions. When this alarm is generated, the active/standby switchover is complete and new Executor resources have been enabled on the new active Manager. In this case, this alarm is cleared. This alarm is used to notify users of the cause of the active/standby Manager switchover.

Alarm Attributes

Alarm ID

Alarm Severity

Auto Cleared

12103

Major

Yes

Alarm Parameters

Parameter

Description

Source

Specifies the cluster or system for which the alarm was generated.

ServiceName

Specifies the service for which the alarm was generated.

RoleName

Specifies the role for which the alarm was generated.

HostName

Specifies the host for which the alarm was generated.

Impact on the System

  • The active/standby Manager switchover occurs.
  • The Executor process keeps restarting. As a result, the cluster page may fail to be accessed.

Possible Causes

The Executor process is abnormal.

Handling Procedure

Check whether the Executor process is abnormal.

  1. In the alarm list on FusionInsight Manager, locate the row that contains the alarm, and click to view the name of the host for which the alarm is generated.
  2. Log in to the host for which the alarm is generated as user root.
  3. Run the su - omm command to switch to user omm.
  4. Run the sh ${BIGDATA_HOME}/om-server/OMS/workspace0/ha/module/hacom/script/status_ha.sh command to check whether the status of the Executor resources managed by the HA is normal. In the single-node system, the Executor resource is in the normal state. In the dual-node system, the Executor resource is in the normal state on the active node and in the stopped state on the standby node.

    • If yes, go to 7.
    • If no, go to 5.

  5. Run the vi $BIGDATA_LOG_HOME/omm/oms/ha/scriptlog/executor.log command to check whether the Executor resource log of HA contains the keyword ERROR. If yes, analyze the log to locate the resource exception cause and fix the exception.
  6. After 5 minutes, check whether this alarm is cleared.

    • If yes, no further action is required.
    • If no, go to 7.

Collect the fault information.

  1. On FusionInsight Manager, choose O&M. In the navigation pane on the left, choose Log > Download.
  2. In the Services area, select Controller and OmmServer, and click OK.
  3. Click in the upper right corner, and set Start Date and End Date for log collection to 1 hour ahead of and after the alarm generation time, respectively. Then, click Download.
  4. Contact O&M personnel and provide the collected logs.

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