Updated on 2024-07-23 GMT+08:00

The Client Log Contains "auth-failure"

Symptom

A client cannot connect to a P2C VPN gateway, and the log contains the following error information:

MANAGEMENT: >STATE:1699599242,RECONNECTING,auth-failure,,,,,
TLS Error: TLS handshake failed

Possible Causes

The certificate and private key in the client configuration file do not match the client CA certificate imported on the Server tab page of the VPN gateway.

Procedure

  • If the client CA certificate imported on the Server tab page of the VPN gateway is incorrect, import the correct CA certificate, delete the incorrect CA certificate, and reconnect the client to the VPN gateway.
  • If the certificate and private key in the client configuration file are incorrect, copy the correct client certificate content and private key to the client configuration file, and reconnect the client to the VPN gateway.