Help Center/ MapReduce Service/ User Guide (Ankara Region)/ Alarm Reference/ ALM-46009 MOTService CPU Usage Exceeds the Threshold
Updated on 2024-11-29 GMT+08:00

ALM-46009 MOTService CPU Usage Exceeds the Threshold

Alarm Description

The system checks the CPU usage of the MOTService every 30 seconds and compares the actual CPU usage with the threshold. This alarm is generated when the CPU usage exceeds the threshold (80% by default) for multiple consecutive times (10 by default).

  • If Trigger Count is 1, this alarm is cleared when the CPU usage is less than or equal to the threshold.
  • If Trigger Count is greater than 1, this alarm is cleared when the CPU usage is less than or equal to 90% of the threshold.

Alarm Attributes

Alarm ID

Alarm Severity

Alarm Type

Service Type

Auto Cleared

46009

Major

Physical resource

MOTService

Yes

Alarm Parameters

Type

Parameter

Description

Location Information

Source

Specifies the cluster or system for which the alarm was generated.

ServiceName

Specifies the service for which the alarm was generated.

RoleName

Specifies the role for which the alarm was generated.

HostName

Specifies the host for which the alarm was generated.

Additional Information

Trigger Condition

Specifies the threshold for triggering the alarm.

Impact on the System

Service processes respond slowly or become unavailable. As a result, the MOTService database cannot provide functions such as data import and query for upper-layer services.

Possible Causes

  • The alarm threshold or alarm trigger count is improperly configured.
  • The CPU configuration cannot meet service requirements, and the CPU usage reaches the upper limit.

Handling Procedure

Check whether the alarm threshold or alarm trigger count is properly configured.

  1. Log in to FusionInsight Manager, choose O&M > Alarm > Thresholds, click the name of the desired cluster, choose MOTService > Database > MOT Used CPU Percentage (MOTServer), and check whether the alarm trigger count and alarm threshold are set properly.

    • If yes, go to 4.
    • If no, go to 2.

  2. Change the trigger count and alarm threshold based on the actual CPU usage, and apply the changes.
  3. Wait 2 minutes and check whether the alarm is automatically cleared.

    • If yes, no further action is required.
    • If no, go to 4.

Check whether the CPU usage reaches the upper limit.

  1. On FusionInsight Manager, choose O&M > Alarm > Alarms. In the right pane, click this alarm and obtain the host name in Location.
  2. Choose Hosts and click the host for which the alarm is generated.
  3. Observe the real-time data of the host CPU usage for about 5 minutes. If the CPU usage exceeds the threshold for multiple times, contact the MRS cluster administrator to increase the CPU.
  4. Check whether the alarm is cleared.

    • If yes, no further action is required.
    • If no, go to 8.

Collect fault information.

  1. On FusionInsight Manager, choose O&M. In the navigation pane on the left, choose Log > Download.
  2. Expand the Service drop-down list and select MOTService.
  3. Expand the Hosts drop-down list. In the Select Host dialog box that is displayed, select the hosts to which the role belongs.
  4. Click the edit icon in the upper right corner, and set Start Date and End Date for log collection to 10 minutes ahead of and after the alarm generation time, respectively. Then, click Download.
  5. Contact O&M personnel/Technical support and provide the collected logs.

Alarm Clearance

This alarm is automatically cleared after the fault is rectified.

Related Information

None