ALM-16047 HiveServer Has Been Deregistered from ZooKeeper
Description
The system checks the Hive service every 60 seconds. This alarm is generated when Hive registration information on ZooKeeper is lost or Hive cannot connect to ZooKeeper.
Attribute
Alarm ID |
Alarm Severity |
Auto Clear |
---|---|---|
16047 |
Major |
Yes |
Parameters
Parameter |
Meaning |
---|---|
Cluster Name |
Specifies the cluster for which the alarm is generated. |
ServiceName |
Specifies the service for which the alarm is generated. |
RoleName |
Specifies the role for which the alarm is generated. |
HostName |
Specifies the host for which the alarm is generated. |
Impact on the System
If the Hive configuration cannot be read from ZooKeeper, HiveServer will be unavailable.
Possible Causes
- The network is disconnected.
- The ZooKeeper instance is abnormal.
Procedure
Restart related instances.
- Log in to FusionInsight Manager. On the FusionInsight Manager home page, choose O&M > Alarm > Alarms, click the drop-down list in the row that contains the alarm. Then check the role name in Location and confirm the IP adress of the instance.
- Choose Cluster > Name of the desired cluster > Services > Hive > Instance, select the instance corresponding to the IP address for which the alarm is generated, and choose More > Restart Instance.
- Wait for 5 minutes and check whether the alarm is cleared.
- If yes, no further action is required.
- If not, go to 4.
Collect the fault information.
- On FusionInsight Manager, choose O&M > Log > Download.
- Expand the Service drop-down list, and select Hive for the target cluster.
- Click in the upper right corner, and set Start Date and End Date for log collection to 10 minutes ahead of and after the alarm generation time, respectively. Then, click Download.
- Contact the O&M personnel and send the collected logs.
Alarm Clearance
After the fault is rectified, the system automatically clears this alarm.
Related Information
None
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