ALM-18000 Yarn Service Unavailable
Alarm Description
The alarm module checks the Yarn service status every 60 seconds. This alarm is generated when the Yarn service is unavailable.
The alarm is cleared when the Yarn service recovers.
Alarm Attributes
Alarm ID |
Alarm Severity |
Auto Cleared |
---|---|---|
18000 |
Critical |
Yes |
Alarm Parameters
Parameter |
Description |
---|---|
Source |
Specifies the cluster for which the alarm is generated. |
ServiceName |
Specifies the service for which the alarm is generated. |
RoleName |
Specifies the role for which the alarm is generated. |
HostName |
Specifies the host for which the alarm is generated. |
Impact on the System
- The cluster cannot provide the Yarn service.
- Users cannot run new applications.
- Submitted applications cannot be run.
Possible Causes
- The ZooKeeper service is abnormal.
- The HDFS service is abnormal.
- There is no active ResourceManager instance in the Yarn cluster.
- All the NodeManager nodes in the Yarn cluster are abnormal.
Handling Procedure
Check ZooKeeper service status.
- On the FusionInsight Manager, check whether the alarm list contains ALM-13000 ZooKeeper Service Unavailable.
- Rectify the fault by performing the operations provided in ALM-13000 ZooKeeper Service Unavailable. Then check whether the alarm is cleared.
- If yes, no further action is required.
- If no, go to Step 3.
Check the HDFS service status.
- On the FusionInsight Manager, check whether the alarm list contains the HDFS alarms.
- Choose O&M > Alarm > Alarms, handle HDFS alarms based on the alarm help, and check whether the Yarn alarm is cleared.
- If yes, no further action is required.
- If no, go to Step 5.
Check the ResourceManager status in the Yarn cluster.
- On FusionInsight Manager, choose Cluster > Services > Yarn.
- On the Dashboard page, check whether there is any active ResourceManager instance in the Yarn cluster.
Check the NodeManager node status in the Yarn cluster.
- On FusionInsight Manager, choose Cluster > Services > Yarn > Instances.
- Query the status of NodeManager and check whether there are unhealthy nodes.
- Rectify the fault by following the steps provided in ALM-18002 NodeManager Heartbeat Lost or ALM-18003 NodeManager Unhealthy. After the fault is rectified, check whether the Yarn alarm is cleared.
- If yes, no further action is required.
- If no, go to Step 10.
Collect fault information.
- On the FusionInsight Manager portal of the active cluster, choose O&M > Log > Download.
- Select Yarn in the required cluster from the Service.
- Click
in the upper right corner, and set Start Date and End Date for log collection to 10 minutes ahead of and after the alarm generation time, respectively. Then, click Download.
- Contact the O&M personnel and send the collected logs.
Alarm Clearance
After the fault is rectified, the system automatically clears this alarm.
Related Information
None
Feedback
Was this page helpful?
Provide feedbackThank you very much for your feedback. We will continue working to improve the documentation.See the reply and handling status in My Cloud VOC.
For any further questions, feel free to contact us through the chatbot.
Chatbot