Help Center/ Database and Application Migration UGO/ FAQs/ Evaluation Project/ What Should I Do If An Object Collection Error (Closed Connection) Is Displayed During Evaluation Project Creation?
Updated on 2024-11-07 GMT+08:00

What Should I Do If An Object Collection Error (Closed Connection) Is Displayed During Evaluation Project Creation?

Symptom

When an evaluation project is being created, Project Status becomes Stopped. Object Collection Error. After you click Object Collection Error, Closed Connection is displayed in the Error column.
Figure 1 Error display

Causes

The collection time for UGO to collect DDL information from the source database was set to 60 seconds. If the size of the database objects to be collected are too large or no data is returned within 60 seconds due to poor database performance or network connection, there may be an object collection error.

Solution

Method 1: Manually submit the SQL statements of the objects that fail to be collected.

  1. Log in to the UGO console.
  2. In the navigation pane on the left, choose Schema Migration > DB Evaluation.
  3. Click the project name to go to the Source DB Analysis page.
  4. Click View Object Details in the Object Statistics area and select a failed schema.
  5. Click Edit SQL in the Operation column and manually import the SQL statement, and save it.
  6. Locate the desired project on the project list page and click Resume in the Operation column.

Method 2: Change the collection time.

  1. Locate the desired project and click Resume in the Operation column.

    Figure 2 Resuming an evaluation task

  2. Change the value of DB Connection Timeout.
  3. Click OK.