Help Center/ Distributed Message Service for Kafka/ Troubleshooting/ Troubleshooting Failure to Log In to Kafka Manager in Windows
Updated on 2022-02-21 GMT+08:00

Troubleshooting Failure to Log In to Kafka Manager in Windows

Symptom

After the Kafka Manager address is entered in the address box of the browser in Windows, the login fails and an error is displayed.

Root Cause

  1. The Windows server and the Kafka instance are not in the same VPC and subnet, or the security group configurations are incorrect.
  2. Kafka Manager is abnormal.

Solution

  1. Check whether the Windows server and the Kafka instance are in the same VPC and subnet.
    • If they are in the same VPC and subnet, go to 2.
    • If they are not in the same VPC and subnet, change the VPC and subnet of the Windows server to the same as those of the Kafka instance.
  2. Check whether the security group is correctly configured. For details on how to configure a security group, see How Do I Select and Configure a Security Group?
    • If the security group is correctly configured, go to 3.
    • If the security group is not correctly configured, modify the configuration.
  3. On the Kafka console, restart Kafka Manager. For details, see Restarting Kafka Manager.