Updated on 2023-11-13 GMT+08:00

Full Phase Error: load table: *** failed

Scenarios

During a full migration or synchronization, an error is reported, and the log information is as follows: service DATAMOVE failed, cause by: load table: `%s`.`%s` failed.

Possible Causes

The table structure of the source database fails to be loaded. The possible cause is that the user deletes tables during synchronization or the source database user does not have required permissions.

Solution

  1. Contact the O&M engineers to check whether the table structure of the source database is normal. The common commands are as follows:
    SELECT * FROM `%s`.`%s` LIMIT 1
    SHOW CREATE TABLE `%s`.`%s`
  2. Contact the source database administrator to check whether the source database and tables have been deleted. If they were deleted, recreate the task by referring to Precautions.
  3. Check whether the migration account has the SHOW CREATE TABLE permission on the source database tables. If the account does not have the permission, grant the permission to the source database migration account by referring to Precautions. Then, in the task list, click Resume in the Operation column to resume the task.