Why Am I Seeing the Message Indicating That the Port Is Used by a One-Click Password Reset Plug-in?
Symptom
When you attempt to run an application on an ECS, the system displays a message indicating that the required port is used by a one-click password reset plug-in.
Possible Causes
If an ECS works in AUTO mode, when its one-click password reset plug-in starts, the plug-in randomly use a port, which may be a service port.
The one-click password reset plug-in has been upgraded to work in PIPE mode by default.
- Newly created ECSs run in PIPE mode by default, and their one-click password reset plug-ins will not use service ports.
- Existing ECSs still work in AUTO mode, in which the plug-ins randomly select idle ports with the smallest port numbers ranging from 31000 to 32999.
Method 1 (Recommended): Modifying the wrapper Files of the One-Click Password Reset Plug-in for the PIPE Mode
In the wrapper files, change AUTO (SOCKET) to PIPE. After the change, the plug-in will not use service ports.
- Open CloudResetPwdAgent configuration files.
- Add the following data to the end of the files:
- Restart CloudResetPwdUpdateAgent.
- Windows
- Press Win+R to start the Run text box.
- Enter services.msc and click OK.
Figure 1 Run
- Right-click cloud reset password update agent and choose Restart from the shortcut menu.
Figure 2 Services (Local)
- Windows
Method 2: Modifying the Configuration to Change the Port Range
Modify the CloudResetPwdAgent configuration to change the default port range (31000–32999) for the password reset plug-in so that the service port is out of the port range.
For example, to change the port range for the password reset plug-in to 40000–42000, perform the following operations:
- Open CloudResetPwdAgent configuration files.
- Add the following data to the configuration files:
wrapper.port.max=41000
wrapper.jvm.port.min=41001
wrapper.jvm.port.max=42000
Figure 3 Modifying the configuration files
- Restart CloudResetPwdUpdateAgent.
- Windows
- Press Win+R to start the Run text box.
- Enter services.msc and click OK.
Figure 4 Run
- Right-click cloud reset password update agent and choose Restart from the shortcut menu.
Figure 5 Services (Local)
- Windows
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