What Do I Do If There Are Too Many Database Connections?
The number of database connections indicates the number of applications that can be simultaneously connected to a database, and is irrelevant to the maximum number of users allowed by your applications or websites.
If there is an excessive number of database connections, applications may fail to be connected, and the full and incremental backups may fail, affecting services.
Troubleshooting
- Check the application connections and release unnecessary connections.
- Check the specifications and upgrade them if needed.
- Cloud Eye monitors database metrics, such as the CPU usage, memory usage, storage space usage, and database connections, and allows you to set alarm rules to identify risks if any alarms are generated. For details, see Cloud Eye User Guide.
Solution
- Connect to a DB instance through a private network. Using a private network prevents congestion caused by insufficient bandwidth.
For details, see Connecting to an RDS for PostgreSQL Instance Through a Private Network.
- On the management console, set the parameter innodb_adaptive_hash_index to off to reduce lock wait time. For operation details, see Modifying Parameters.
- Optimize slow queries.
What is your overall rating for this page?
Thank you very much for your feedback. We will continue working to improve the documentation.See the reply and handling status in My Cloud VOC.
For any further questions, feel free to contact us through the chatbot.
Chatbot