ALM-12073 CEP Resource Is Abnormal
Description
HA checks the cep resources of Manager every 60 seconds. This alarm is generated when HA detects that the cep resources are abnormal for 2 consecutive times.
This alarm is cleared when the CEP resource is normal.
Resource Type of CEP is Single-active. Active/standby will be triggered upon resource exceptions. When this alarm is generated, the active/standby switchover is complete and new CEP resources have been enabled on the new active FusionInsight Manager. In this case, this alarm is cleared. This alarm is used to notify users of the cause of the active/standby switchover.
Attribute
Alarm ID |
Alarm Severity |
Auto Clear |
---|---|---|
12073 |
Major |
Yes |
Parameters
Name |
Meaning |
---|---|
Source |
Specifies the cluster or system for which the alarm is generated. |
ServiceName |
Specifies the service for which the alarm is generated. |
RoleName |
Specifies the role for which the alarm is generated. |
HostName |
Specifies the host for which the alarm is generated. |
Impact on the System
- The active/standby FusionInsight Manager switchover occurs.
- The CEP process repeatedly restarts, causing monitoring data to be abnormal.
Possible Causes
The CEP process is abnormal.
Procedure
Check whether the CEP process is abnormal.
- In the alarm list on FusionInsight Manager, locate the row that contains the alarm, and view the name of the host for which the alarm is generated.
- Log in to the host for which the alarm is generated as user root.
- Run the su -omm command and then the sh ${BIGDATA_HOME}/om-server/OMS/workspace0/ha/module/hacom/script/status_ha.sh command to check whether the status of the CEP resources managed by the HA is normal. In the single-node system, the CEP resource is in the normal state. In the dual-node system, the CEP resource is in the normal state on the active node and in the stopped state on the standby node.
- Run the vi $BIGDATA_LOG_HOME/omm/oms/cep/cep.log and vi $BIGDATA_LOG_HOME/omm/oms/cep/scriptlog/cep_ha.log commands to view the CEP resource logs, check whether the keyword ERROR exists. Analyze the logs to locate and rectify the fault.
- Five minutes later, check whether this alarm is cleared.
- If it is, no further action is required.
- If it is not, go to 6.
Collect fault information.
- On FusionInsight Manager, choose O&M > Log > Download.
- Select Controller and OmmServer for Service and click OK.
- Click in the upper right corner. In the displayed dialog box, set Start Date and End Date to 1 hour before and after the alarm generation time respectively and click OK. Then, click Download.
- Contact the O&M personnel and send the collected log information.
Alarm Clearing
This alarm will be automatically cleared after the fault is rectified.
Related Information
None
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