Help Center/ Elastic Cloud Server/ FAQs/ Disk Partition, Attachment, and Expansion FAQ/ What Should I Do If Attaching a Disk to a Windows ECS Failed But There Are Still Available Device Names?
Updated on 2024-09-29 GMT+08:00

What Should I Do If Attaching a Disk to a Windows ECS Failed But There Are Still Available Device Names?

Symptom

On the Windows ECS details page, the system displays a message indicating that at most n more disks can be attached to the ECS. However, after you clicked Attach Disk, the attachment failed.

Figure 1 Disk attachment

Possible Causes

If an EVS disk in arrears is not renewed, the system forcibly uninstalls it, which may cause a residual drive letter on the Windows ECS. As a result, the actual number of available device names on the ECS is less than the displayed number.

Solution

Restart the ECS and attach the disk again.

If the attaching still fails, contact customer service for technical support.