Help Center/ Elastic Cloud Server/ FAQs/ Remote Login FAQ/ VNC Login/ Why No Audio File Can Be Properly Played on My Windows ECS Logged In Using VNC?
Updated on 2024-10-16 GMT+08:00

Why No Audio File Can Be Properly Played on My Windows ECS Logged In Using VNC?

Symptom

When I logged in to my Windows ECS using MSTSC, audio files can be properly played. However, when I logged in to that ECS using VNC, audio files failed to be played.

Possible Causes

VNC does not support audio playing.

Solution

Use your local PC (running Windows 7, for example) to play the audio files.

  1. Start your local PC.

    Start your local PC, instead of logging in to your Windows ECS.

  2. Press Win+R to start the Run text box.
  3. Enter mstsc and click OK.

    The Remote Desktop Connection window is displayed.

    Figure 1 Remote Desktop Connection
  4. Click Options in the lower left corner and click the Local Resources tab.
    Figure 2 Local Resources
  5. In the Remote audio pane, click Settings.
    Figure 3 Setting remote audio playback
  6. In the Remote audio playback pane, select Play on this computer.