What Can I Do If the Partition Capacity Fails to Be Expanded Using growpart After the EVS Disk Capacity Is Expanded?
Symptom
After the capacity of an EVS disk is expanded, running the growpart command to expand the partition capacity fails. The error information is as follows:
Possible Cause
After expanding the capacity of an EVS disk, you need to expand the capacity of its partitions and file system. If the partitions are not aligned during initialization, the partition capacity may fail to be expanded using the growpart command.
Run the parted -l command. If the value in the Start column is not 2048s or 1049KB, the partitions are not aligned.
Solution
If partitions are not aligned, their capacity cannot be automatically expanded. You need to manually expand the capacity or repartition the disk.
This section describes how to manually expand the capacity of disk partitions.
Repartitioning disks will cause data loss. Exercise caution when performing this operation.
Manual capacity expansion may be risky, so you need to back up data before performing this operation. For details, see Creating a Snapshot or Creating a Cloud Disk Backup.
- Log in to a Linux ECS.
- Stop the processes related to the mount directory.
- Run the following command to uninstall sdb1 (as an example):
umount /dev/sdb1
- Run the following command to manually expand the capacity:
- Run the p command to check the current partition.
- Run the following command to select a partition for capacity expansion:
You must select the last partition because only its capacity can be expanded.
resizepart 1 (Partition number, partition 1 is used as an example in this command) 100%
- Run the p command to check whether the partition capacity is expanded.
Figure 4 Partition capacity expansion
- Run the q command to exit the parted interaction mode. The partition capacity is manually expanded.
Feedback
Was this page helpful?
Provide feedbackThank you very much for your feedback. We will continue working to improve the documentation.See the reply and handling status in My Cloud VOC.
For any further questions, feel free to contact us through the chatbot.
Chatbot