Help Center/ Cloud Search Service/ Troubleshooting/ Unavailable Clusters/ What Can I Do If My Custer Is Unavailable Due to an X-pack Parameter Configuration?
Updated on 2024-08-27 GMT+08:00

What Can I Do If My Custer Is Unavailable Due to an X-pack Parameter Configuration?

Symptom

The cluster status is Unavailable, and the task status of the cluster is Configuration error. Restart failed.

Figure 1 Incorrect cluster configuration

Possible Causes

You have configured custom X-pack parameters. CSS does not support the X-pack function.

Procedure

  1. On the Clusters page, click the name of the unavailable cluster. The Cluster Information page is displayed.
  2. Choose Parameter Configurations, expand the Customize module, and check whether custom X-pack parameters exist.

    Examples of the custom X-pack parameters:

    • xpack.security.enabled: true
    • xpack.security.http.ssl.enabled: true
    • xpack.security.http.ssl.keystore.path: "http.p12
    • If yes, go to the next step.
    • If no, contact technical support to locate the parameter configuration problem.

  3. Delete the custom X-pack parameters.
    1. Click Edit and click Delete on the right of the parameter you want to be delete.
    2. Click Submit. In the displayed Submit Configuration dialog box, select I understand that the modification will take effect after the cluster is restarted. and click OK.

      If the Status is Successful in the parameter modification list, the modification has been saved.

    3. Return to the cluster list and choose More > Restart in the Operation column to restart the cluster and make the modification take effect.
    4. After the cluster is restarted, the cluster becomes available.