What Are the Possible Causes for Data Corruption of an RDS Instance?
- Data tampering
Lots of security measures are provided to ensure that only authenticated users have permissions to perform operations on database table records. Database tables can be accessed only through specific database ports.
Verifying package during primary/standby synchronization can prevent data tampering. RDS for MySQL uses the InnoDB storage engine to prevent data from being damaged.
- DB instance servers may be powered off suddenly, causing database page corruption and database rebooting failures.
If a primary node encounters a failure, the system fails over to the standby node within 1 to 5 minutes to continue providing service. During the failover, RDS instances are temporarily inaccessible. Make sure that automatic reconnection has been configured for your application to prevent service unavailability caused by the failover.
What is your overall rating for this page?
Thank you very much for your feedback. We will continue working to improve the documentation.See the reply and handling status in My Cloud VOC.
For any further questions, feel free to contact us through the chatbot.
Chatbot