ALM-29005 Number of JDBC Connections to Impalad Exceeds the Threshold
Description
The system checks the number of client connections to the Impalad node every 30 seconds. This alarm is generated when the number of client connections exceeds the customized threshold (60 by default).
This alarm is automatically cleared when the number of client connections is less than the threshold.
Attribute
Alarm ID |
Alarm Severity |
Automatically Cleared |
---|---|---|
29005 |
Major |
Yes |
Parameters
Name |
Meaning |
---|---|
Source |
Specifies the cluster for which the alarm is generated. |
ServiceName |
Specifies the service for which the alarm is generated. |
RoleName |
Specifies the role for which the alarm is generated. |
HostName |
Specifies the host for which the alarm is generated. |
Trigger Condition |
Specifies the threshold for triggering the alarm. |
Impact on the System
New client connections may be blocked or even fail.
Possible Causes
The number of client connections maintained by the Impalad service is too large or the threshold is too small.
Procedure
- On FusionInsight Manager, choose O&M > Alarm > Thresholds > Impala > Connections > Number of JDBC Connections to Impalad Process to check the configured threshold.
- Check the number of JDBC applications connected to Impalad and stop idle applications. Check whether the alarm is automatically cleared.
- If yes, no further action is required.
- If no, go to 3 to change the number of concurrent client connections.
- On FusionInsight Manager, choose Cluster > Impala > Configurations > All Configurations > Impalad > Customization. Add the customized parameter --fe_service_threads. The default value of this parameter is 64. Change the value as required and click Save.
- After the query tasks on all clients are complete, click the Instance tab. Select all Impalad instances, and restart them.
- After the restart is complete, the alarm is cleared. Run the application that uses JDBC to connect to Impalad again.
Alarm Clearing
After the fault that triggers the alarm is rectified, the alarm is automatically cleared.
Related Information
None
Feedback
Was this page helpful?
Provide feedbackThank you very much for your feedback. We will continue working to improve the documentation.See the reply and handling status in My Cloud VOC.
For any further questions, feel free to contact us through the chatbot.
Chatbot