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Atualizado em 2024-01-04 GMT+08:00

Como corrigir um agente anormal?

Seu agente provavelmente está anormal se estiver no estado Not installed ou Offline. Os status dos agentes e seus significados são os seguintes:

  • Uninstalled: nenhum agente foi instalado no servidor ou o agente foi instalado, mas não iniciado.
  • Offline: a comunicação entre o agente e o servidor é anormal. O agente no servidor foi excluído ou um servidor não da HUAWEI CLOUD está off-line.
  • Online: o agente no servidor está funcionando corretamente.

Possíveis causas

  • O status do agente no console não é atualizado.

    O status do agente não foi atualizado. Depois que o agente é instalado, leva de 5 a 10 minutos para que o console atualize seu status.

  • Versão do SO não suportada.

    Para obter detalhes, consulte SOs suportados.

  • A rede está com defeito.

    O agente ou a central de proteção de nuvem é anormal. Por exemplo, a NIC é defeituosa, o endereço IP é alterado ou a largura de banda é baixa.

  • O processo do agente é anormal.

Solução

  1. Verifique se o status do agente permanece Offline no console por mais de 10 minutos após a instalação do agente.

    • Se sim, vá para 2.
    • Se não, aguarde até que o agente fique on-line. Nenhuma ação adicional é necessária. Depois que o agente é instalado, leva de 5 a 10 minutos para o console atualizar seu status.

  2. Verifique se o SO do servidor está dentro do escopo de suporte em SOs suportados.

    • Se sim, vá para 3.
    • Se não, o agente do HSS não pode ser instalado ou executado no servidor. Atualize o SO para uma versão suportada pelo HSS e tente novamente.

  3. Verifique se a rede do servidor está normal.

    • Se sim, vá para 4.
    • Se não, verifique se o grupo de segurança do servidor permite o acesso à porta 10180 do bloco CIDR 100.125.0.0/16 na direção de saída e se o servidor pode acessar a rede. Depois que o servidor puder acessar a rede, verifique o status do agente.

  4. Reinicie o processo do agente.

    • Windows
      1. Efetue logon no servidor como usuário administrator.
      2. Abra o Gerenciador de tarefas.
      3. Na página de guia Services, selecione HostGuard.
      4. Clique com o botão direito do mouse no serviço e escolha Restart.
    • Linux

      Execute o seguinte comando na CLI como usuário root para reiniciar o agente:

      service hostguard restart

      Se as informações a seguir forem exibidas, a reinicialização foi bem-sucedida:
      root@HSS-Ubuntu32:~#service hostguard restart
      Stopping Hostguard...
      Hostguard stopped
      Hostguard restarting...
      Hostguard is running

    Depois que o processo for reiniciado, aguarde cerca de 2 minutos.

    • Se o status do agente for Online, nenhuma ação adicional será necessária.
    • Se o status do agente ainda for Not installed ou Offline, desinstale o agente e instale-o novamente.