Por que não consigo obter a senha para efetuar logon no meu ECS de Windows autenticado usando um par de chaves?
Sintoma
Uma chave privada não pode ser usada para obter a senha para fazer logon em um ECS de Windows que é autenticado usando um par de chaves.
Possíveis causas
- Uma falha de rede, levando à falha da conexão do ECS ao servidor Cloudbase-Init.
- Nenhuma configuração na imagem para o Cloudbase-Init obter a senha.
- Outras razões.
Solução
Se o logon em um ECS com Cloudbase-Init habilitado falhar, execute as seguintes operações para localizar a falha:
- Verifique se o Cloudbase-Init foi configurado corretamente na imagem usada para criar o ECS.
- Se o Cloudbase-Init não tiver sido configurado, o ECS não permitirá configurações personalizadas e você poderá fazer logon nele somente usando a senha da imagem original.
- Os ECSs criados usando uma imagem pública têm o Cloudbase-Init instalado por padrão. Portanto, você não precisa mais instalar e configurar o Cloudbase-Init.
- Se você criou seu ECS usando um arquivo de imagem externo, instale e configure o Cloudbase-Init.
Para obter detalhes, consulte Instalação e configuração do Cloudbase-Init.
- Certifique-se de que o par de chaves para fazer logon no ECS esteja correto.
A chave usada para obter a senha deve ser a chave usada durante a criação do ECS.
- Certifique-se de que o DHCP esteja habilitado na VPC à qual o ECS pertence.
No console de gerenciamento, verifique se o DHCP foi habilitado na sub-rede de destino.
Figura 1 DHCP - Certifique-se de que o ECS tem um ECS vinculado.
- Certifique-se de que o tráfego de e para a porta 80 esteja permitido nas regras do grupo de segurança.
Figura 2 Regras de grupo de segurança para a porta 80
- Verifique os logs do Cloudbase-Init para identificar a causa.
- Interrompa o ECS afetado e desanexe o disco do sistema dele.
Figura 3 Desanexar o disco do sistema
- Use uma imagem pública para criar um ECS de Windows temporário e anexar o disco do sistema desanexado em 6.a ao ECS
- Faça logon no ECS temporário, abra a página Server Manager, escolha File and Storage Services > Volumes > Disks, clique com o botão direito do mouse no disco off-line e escolha Online no menu de atalho.
Figura 4 Colocar o disco on-line
- Alterne para o arquivo cloudbase-init em /Program Files/Cloudbase Solution/Cloudbase-Init/log deste disco para exibir o log de localização de falhas.
Figura 5 cloudbase-init
- Interrompa o ECS afetado e desanexe o disco do sistema dele.