Este conteúdo foi traduzido por máquina para sua conveniência e a Huawei Cloud não pode garantir que o conteúdo foi traduzido com precisão. Para exibir o conteúdo original, use o link no canto superior direito para mudar para a página em inglês.
Central de ajuda/
Elastic Cloud Server/
Perguntas frequentes/
Login and Connection/
Remote Login Errors on Linux/
O que devo fazer se a mensagem de erro "read: Connection reset by peer" for exibida quando faço logon remotamente em um ECS de Linux?
Atualizado em 2025-01-23 GMT+08:00
O que devo fazer se a mensagem de erro "read: Connection reset by peer" for exibida quando faço logon remotamente em um ECS de Linux?
Sintoma
Quando tentei fazer logon remotamente em um ECS de Linux, o sistema exibia a mensagem de erro "read: Connection reset by peer".
Figura 1 read: Connection reset by peer

Possíveis causas
- A porta de logon remoto não é permitida no grupo de segurança.
- O firewall é habilitado no ECS, mas a porta de logon remoto é bloqueada pelo firewall.
Solução
Execute as seguintes operações para solução de problemas:
- Verifique as regras do grupo de segurança.
- Entrada: adicione a porta de logon remoto. A porta padrão 22 é usada como exemplo.
- Saída: as regras de saída permitem que o tráfego de rede esteja fora das portas especificadas.
- Adicione uma porta à exceção de firewall do ECS.
O seguinte usa o Ubuntu como exemplo:
- Execute o seguinte comando para visualizar o status do firewall:
As seguintes informações são exibidas:
Status: active
- Adicione uma porta à exceção do firewall, tomando a porta padrão 22 como exemplo.
Rule added
Rule added (v6)
- Execute o seguinte comando para verificar o status do firewall novamente:
Status: active To Action From -- ------ ---- 22 ALLOW Anywhere 22 (v6) ALLOW Anywhere (v6)
Tente fazer logon remotamente no ECS novamente.
- Execute o seguinte comando para visualizar o status do firewall:
Tópico principal: Remote Login Errors on Linux
Feedback
Esta página foi útil?
Deixar um comentário
Obrigado por seus comentários. Estamos trabalhando para melhorar a documentação.
O sistema está ocupado. Tente novamente mais tarde.