Updated on 2023-04-03 GMT+08:00

Incremental Phase Error: Table *** not found in database

Scenarios

During an incremental migration or synchronization, an error is reported, and the log information is as follows: service INCREMENT failed, cause by: Table %s not found in database

Possible Causes

The possible causes are as follows:

  • Tables are deleted from the destination database. As a result, the synchronization statement reports an error.
  • Incremental DDLs is not selected for Synchronize during task creation. After a table is created in the source database, DDL statements are filtered out. As a result, an error is reported during synchronization.

Solution

Contact the destination database O&M engineers to create a table in the destination database based on the table structure of the source database. After the table is created, click Resume in the Operation column to resume the task.