Updated on 2023-01-17 GMT+08:00

Incremental Phase Error: Table *** doesn't exist

Scenarios

During an incremental migration or synchronization, an error is reported, and the log information is as follows: service INCREMENT failed, cause by: Table ' %s' doesn't exist; sql is: create %s like matches

Possible Causes

Tables are deleted from the destination database. As a result, the synchronization statement reports an error.

Solution

  1. Contact destination database O&M engineers to create a table in the destination database based on the table structure of the source database.
  2. After the table is created, click Resume in the Operation column to resume the task.