Updated on 2023-01-17 GMT+08:00

Incremental Phase Error: Table *** already exists

Scenarios

During an incremental migration or synchronization, an error is reported, and the log information is as follows: service INCREMENT failed, cause by: Table ' %s' already exists

Possible Causes

A table has been created in the destination database. As a result, an error is reported when the DDL statement for creating a table in the source database is executed.

Solution

  1. Contact destination database O&M engineers to delete the corresponding table from the destination database.
  2. In the task list, locate the target task and click Resume in the Operation column to resume the task.