ALM-50216 Memory Usage of the FE Node Exceeds the Threshold
Alarm Description
The system checks the memory usage of the FE node every 30 seconds. This alarm is generated when the memory usage exceeds the threshold (95% by default).
This alarm is cleared when the memory usage of the FE node falls below the threshold.
Alarm Attributes
Alarm ID |
Alarm Severity |
Alarm Type |
Service Type |
Auto Cleared |
---|---|---|---|---|
50216 |
Major |
Quality of service |
Doris |
Yes |
Alarm Parameters
Type |
Parameter |
Description |
---|---|---|
Location Information |
Source |
Specifies the cluster or system for which the alarm is generated. |
ServiceName |
Specifies the service for which the alarm is generated. |
|
RoleName |
Specifies the role for which the alarm is generated. |
|
HostName |
Specifies the host for which the alarm is generated. |
|
Additional Information |
Detail |
Specifies the alarm triggering condition. |
Impact on the System
Task execution and client connection to the FE are affected.
Possible Causes
The FE heap memory is too small.
Handling Procedure
Check the FE heap memory usage.
- Log in to FusionInsight Manager, choose O&M > Alarm > Thresholds, select the name of the desired cluster, and choose Doris > CPU and Memory > Memory usage of the FE node (FE).
- Click the edit button next to Trigger Count, change the number based on site requirements, and click OK.
- Click Modify in the Operation column, change the alarm threshold based on site requirements, and click OK.
- Log in to the FE node for which the alarm is generated as user omm, run the top command to check the memory usage of processes, locate the process with high memory usage, and check whether the process belongs to the current service and is running properly.
- If yes, go to 3.
- If no, isolate or stop the process, or adjust the memory size, and check whether the memory is released.
- Restart the affected services or instances and check whether the alarm is cleared.
- If yes, no further action is required.
- If no, go to 4.
Collect fault information.
- On FusionInsight Manager, choose O&M. In the navigation pane on the left, choose Log > Download.
- Expand the Service drop-down list, and select Doris for the target cluster.
- Click the edit icon in the upper right corner, and set Start Date and End Date for log collection to 10 minutes ahead of and after the alarm generation time, respectively. Then, click Download.
- Contact O&M engineers and provide the collected logs.
Alarm Clearance
This alarm is automatically cleared after the fault is rectified.
Related Information
None.
Feedback
Was this page helpful?
Provide feedbackThank you very much for your feedback. We will continue working to improve the documentation.See the reply and handling status in My Cloud VOC.
For any further questions, feel free to contact us through the chatbot.
Chatbot