ALM-38000 Kafka Service Unavailable
Description
The system checks the Kafka service status every 30 seconds. This alarm is generated when the Kafka service is unavailable.
This alarm is cleared when the Kafka service recovers.
Attribute
Alarm ID |
Alarm Severity |
Automatically Cleared |
---|---|---|
38000 |
Critical |
Yes |
Parameters
Name |
Meaning |
---|---|
Source |
Specifies the cluster for which the alarm is generated. |
ServiceName |
Specifies the service for which the alarm is generated. |
RoleName |
Specifies the role for which the alarm is generated. |
HostName |
Specifies the host for which the alarm is generated. |
Impact on the System
The cluster cannot provide the Kafka service, and users cannot perform new Kafka tasks.
Possible Causes
- The KrbServer service is abnormal.(Skip this step if the normal mode is used.)
- The ZooKeeper service is abnormal or does not respond.
- The Broker instance in the Kafka cluster are abnormal.
Procedure
Check the status of the KrbServer service. (Skip this step if the normal mode is used.)
- On the FusionInsight Manager portal, choose Cluster > Name of the desired cluster > Services > KrbServer.
- Check whether the running status of the KrbServer service is Normal.
- Rectify the fault by following the steps provided in ALM-25500 KrbServer Service Unavailable.
- Perform 2 again.
Check the status of the ZooKeeper cluster.
- Check whether the running status of the ZooKeeper service is Normal.
- If ZooKeeper service is stopped, start it, else rectify the fault by following the steps provided in ALM-13000 ZooKeeper Service Unavailable.
- Perform 5 again.
Check the Broker status.
- Choose Cluster > Name of the desired cluster > Services > Kafka > Instance to go to the Kafka instances page.
- Check whether all instances in Roles are running properly.
- Select all Broker instances, choose More > Restart Instance, and check whether the instances restart successfully.
- Choose Cluster > Name of the desired cluster > Services > Kafka to check whether the running status is Normal.
- Wait for 30 seconds and check whether the alarm is cleared.
- If yes, no further action is required.
- If no, go to 13.
Collecting Fault Information
- On the FusionInsight Manager portal, choose O&M > Log > Download.
- Select Kafka in the required cluster from the Service drop-down list.
- Click in the upper right corner, and set Start Date and End Date for log collection to 10 minutes ahead of and after the alarm generation time, respectively. Then, click Download.
- Contact the O&M personnel and send the collected logs.
Alarm Clearing
After the fault is rectified, the system automatically clears this alarm.
Related Information
None
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