Help Center/ Elastic Cloud Server/ FAQs/ ECS Creation/ What Do I Do If I Cannot Find My ECSs?
Updated on 2025-06-27 GMT+08:00

What Do I Do If I Cannot Find My ECSs?

Symptom

You cannot find your purchased ECSs after logging in to the console.

Possible Causes

The ECS is not in the current region.

Solution

Method 1

  1. Log in to the management console.
  2. Select the region in which you created your ECS.
    Figure 1 Changing a region on the management console homepage

Solution 2:

  1. Log in to the management console.
  1. On the right of the top navigation bar of the management console, choose Resources > My Resources.
    Figure 2 My Resources
  2. On the My Resources page, view resource details.
    • Click a resource type to display all resources of the resource type in the list.
    • Click a region to view all resources in the region.
    Figure 3 Resource list