Help Center/ CodeArts Deploy/ FAQs/ Common FAQs/ What Should I Do If the Connection Times Out Occasionally During a Deployment on a Windows Host?
Updated on 2024-08-06 GMT+08:00

What Should I Do If the Connection Times Out Occasionally During a Deployment on a Windows Host?

Symptoms

During a deployment on a Windows host, the "Connection to ***.***.***.** timed out." message is occasionally displayed.

Cause Analysis

Possible cause:

During TCP connect scan, the port is occupied and is not released in time.

Solution

  1. Press Win+R to open the Run window, enter regedit to open the Registry Editor window, and locate the following path:
  2. HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters

  3. In the right pane, find the DWORD value of TcpTimedWaitDelay. Create one if it does not exist.
  4. Change the value of TcpTimedWaitDelay to a required value (in milliseconds). For example, set the TcpTimedWaitDelay value to 1 minute (60,000 milliseconds).
  5. Restart the PC to validate the configuration.

    Changing the value of TcpTimedWaitDelay may affect network performance and security. Make the change based on your service requirements. For multiple target Windows hosts in the same environment, batch deployment is recommended to avoid unknown impact caused by changing the value of TcpTimedWaitDelay.