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- What's New
- Function Overview
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Product Bulletin
- [January 23, 2025] CAs Suspend OV and EV SSL Certificate Approval and Issuance During the Spring Festival
- [December 24, 2024] CA Venders Suspend Certificate Issuance During Christmas and New Year's Day
- [October 28, 2024] Notice on Switching the DigiCert Root Certificate
- [July 29, 2024] Notice on DigiCert and GeoTrust SSL Certificate Price Changes
- [October 8, 2023] Validity Period Change of Test Certificates
- [April 17, 2023] Changing GeoTrust DV to RapidSSL DV
- [Feb 8, 2023] Notice on DigiCert Root Certificate Update
- [December 16, 2022] DigiCert and GeoTrust Suspend OV and EV Certificate Validation During Christmas Holidays
- [September 13, 2022] SSL Certificate Chains Embedded in Applications May Cause Communication Failures
- [July 25, 2022] Organization Unit (OU) Field Removed from SSL Certificates
- [March 23, 2022] SSL Certificate Manager Entry Will Be Changed on March 25, 2022
- [Product Notices] Huawei Cloud SCM Domain Ownership Verification Policy (File-based Verification) Changed on Nov 12, 2021
- [August 20, 2020] Notice on the Change of the Maximum Validity Period of SSL Certificates
- [August 14, 2020] Notice on Delaying Issuance of EV and EV Pro Certificates Due to the DigiCert System Failure
- [July 27, 2020] CAs Will No Longer Issue Two-Year SSL Certificates
- [July 27, 2020] Notice on Revocation of DV Certificates by CAs
- [July 19, 2020] DigiCert System Maintenance Notice
- [May 31, 2020] GlobalSign System Maintenance Notice
- [May 3, 2020] DigiCert System Maintenance Notice
- [April 26, 2020] Symantec Certificate Brand Change Notice
- Service Overview
- Billing
- Getting Started
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SSL Certificate Manager (SCM) User Guide
- About SCM and SSL Certificate Usage
- Purchasing an SSL Certificate
- Applying for an SSL Certificate
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Installing an SSL Certificate
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Installing an SSL Certificate on a Web Server
- Downloading an SSL Certificate
- Downloading a Root Certificate
- Installing an SSL Certificate on a Tomcat Server
- Installing an SSL Certificate on an Nginx Server
- Installing an SSL Certificate on an Apache Server
- Installing an SSL Certificate on an IIS Server
- Installing an SSL Certificate on a WebLogic Server
- Installing an SSL Certificate on a Resin Server
- Deploying an SSL Certificate to Other Huawei Cloud Products
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Installing an SSL Certificate on a Web Server
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Managing SSL Certificates
- Reissuing an SSL Certificate
- Unsubscribing from an SSL Certificate
- Renewing an SSL Certificate
- Revoking an SSL Certificate
- Re-applying for a Revoked SSL Certificate
- Deleting an SSL Certificate from CCM
- Uploading an External Certificate to SCM
- Adding an Additional Domain Name
- Withdrawing an SSL Certificate Application
- Canceling Authorization for Privacy Information
- Pushing an SSL Certificate to Other Cloud Services
- Viewing Details About an SSL Certificate
- Viewing the Application Progress
- CSRs
- Sharing
- Managing Tags
- Permissions Management
- Private Certificate Authority (PCA) User Guide
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Best Practices
- CCM Best Practice Summary
- Best Practices for SSL Certificate Manager
- Best Practices for Private Certificate Management
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API Reference
- Before You Start
- Calling APIs
- API Overview
- API Description
- Examples
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Historical APIs
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SCM APIs
- Purchasing an SSL Certificate
- Querying the Certificate List
- Querying Details of a Certificate
- Modifying a Certificate
- Querying the Product Type of a Certificate
- Querying the Product Details of a Certificate
- Applying for a Certificate
- Verifying a CSR
- Saving Certificate Information
- Reading the Information Entered When Applying for a Certificate
- Canceling an Application
- Deleting a Certificate
- Uploading Authentication Information
- Downloading a Certificate
- Uploading a Certificate
- Revoking a Certificate
- Pushing a Certificate
- Querying Push Records
- Canceling Authorization for Privacy Information
- Adding an Additional Domain Name
- Querying Domain Name Verification Information
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SCM APIs
- Permissions and Supported Actions
- Appendix
- Change History
- SDK Reference
-
FAQs
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Certificate Consulting
- What Are the Differences Between SSL Certificate Manager and Private Certificate Authority?
- Which Websites Require HTTPS?
- What Are the Differences Between HTTPS and HTTP?
- What Is a Public Key and a Private Key?
- What Are the Relationships Between a Public Key, Private Key, and Digital Certificate?
- Why Is a Non-Password-Protected Private Key Required?
- What Are Mainstream Formats of Digital Certificates?
- What Information Does an SSL Certificate Contain?
- Can I Use SSL Certificates for Other Regions, Accounts, or Platforms?
- Can I Use an Unused SSL Certificate Anytime I Want?
- Can SSL Certificates Be Upgraded?
- Does the SSL Certificate Have Restrictions on the Server Port?
- Why Is SCM Inaccessible or the Operation Button Grayed Out When I Access the SCM Console?
- Regions and AZs
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SSL Certificate Application and Purchase
- SSL Certificate Selection
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About Required Domain Name Details
- How Do I Enter a Domain Name for a Certificate When Applying for an SSL Certificate?
- What Are the Differences Between a Single-Domain Name, Multi-Domain Name, and Wildcard-Domain Name in SCM?
- What Is the Relationship Between a Domain Name and an SSL Certificate?
- What Domains Can Wildcard-Domain Certificates Support?
- What Domain Name Should I Use to Apply for an SSL Certificate?
- Can I Change the Primary Domain Name Associated with a Certificate?
- Does the Relationship Between the Primary Domain Name and Additional Domain Name Have Any Impact on Domain Names?
- How Do I Make a CSR File?
- What Are the Differences Between the CSR Generated by the System and the CSR Made by Yourself?
- How Do I Export a CSR File?
- Domain-related Concepts
- Problems Related to Domains
- About Required Information
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Troubleshooting
- What Can I Do If I Encounter a Problem When Purchasing, Applying for, Installing, or Using a Free SSL Certificate?
- What Can I Do If the Submit Button Is Unavailable?
- Can I Change Certificate Information After I Submit a Certificate Application?
- What Can I Do If I Encounter a Problem During SSL Certificate Application?
- About Test Certificates
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Domain Name Ownership Verification
- How Do I Verify Domain Ownership?
- How Do I Verify the Domain Ownership Manually by DNS?
- How Do I Perform Verification by File?
- How Do I Perform Verification by Email?
- How Do I Check Whether Domain Name Verification Takes Effect?
- How Can I Check Whether DNS Verification Takes Effect for Windows OSs?
- What Can I Do If Domain Ownership Verification Does Not Take Effect?
- How Do I Query a Domain Name Provider?
- How Do I Query and Verify the Email Address of the Domain Administrator?
- How Do I Use DNS to Verify Domains Not Hosted on Huawei Cloud?
- Why Does the SSL Certificate Remain in the Pending Domain Name Verification State (Application Progress Is 40%) After Domain Name Verification Is Complete?
- How Do I Change the Domain Name Verification Mode When the SSL Certificate Status Is Pending domain name verification?
- What Do I Do If DNS Verification for a DV Certificate Fails?
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SSL Certificate Approval
- How Long Does It Take to Approve an SSL Certificate?
- Why Does the Certificate Stay in the CA Verifying Status for a Long Time?
- What Can I Do After I Submit an SSL Certificate Application?
- How Do I Handle the Email or Phone Call from the CA?
- Do I Need to Get a Newly Purchased SSL Certificate Approved?
- What Can I Do When I Fail to Pass the Security Review?
- What Can I Do When a Message Indicating Approval Failure Due to Blank Main Domain Name Is Displayed?
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SSL Certificate Download, Installation, and Use
- SSL Certificate Download
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SSL Certificate Installation
- On Which Servers Can an SSL Certificate Be Deployed?
- How Do I Install an SSL Certificate on a Server?
- How Do I Check Whether the Deployed SSL Certificate Takes Effect?
- Is the Original SSL Certificate Still Available After a Server IP Address Is Changed?
- In Which Geographical Locations Can an SSL Certificate Be Used?
- How Do I Add an SSL Certificate to the Background of a Website Built by Baota?
- How Do I Solve Problems Related to SSL Certificate Installation or Use?
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SSL Certificate Use
- How Do I Configure a Non-Huawei Cloud SSL Certificate for a Huawei Cloud Product?
- How Do I Apply an SSL Certificate to Other Huawei Cloud Services?
- Which Region Will a Certificate Be Deployed to When I Deploy an SSL Certificate in CCM to Other Cloud Product?
- Is HTTPS Automatically Enabled After an SSL Certificate Is Deployed to a Cloud Product?
- How Do I Solve the Problem That Occurs When I Use Certificates in WAF, ELB, or CDN?
- Why Is a Message Indicating that the Certificate Chain Is Incomplete Displayed When I Configure HTTPS on CDN?
- Why Is an Error Reported When I Deploy an SSL Certificate with an Uploaded CSR to WAF, ELB, or CDN?
- How Do I Use an SSL Certificate After It Is Issued?
- What Can I Do If My SSL Certificate Cannot Be Deployed to Other Services?
- Issues Related to SSL Certificate Uploading
- What Can I Do If Errors Are Reported When I Upload an SSL Certificate?
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SSL Certificate Troubleshooting
- What Can I Do If the Browser Displays a Message Indicating that the SSL Certificate Is Untrusted?
- Why Does the Browser Still Consider the Website Insecure While the Website Has an SSL Certificate Deployed?
- Why Is My Website Inaccessible by Domain Name After an SSL Certificate Is Installed?
- Why Does the HTTPS Access Speed Become Slower After an SSL Certificate Is Installed?
- Why Does the Browser Prompt a Not Secure Warning to Visitors After I Configure an SSL Certificate for the Website?
- What Can I Do If the Browser Displays "Your Connection Is Not a Private Connection"?
- Will the Browser Prompt A Warning Indicating the Deployed SSL Certificate Is Not Secure?
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Certificate Validity Period
- What Can I Do If My SSL Certificate Expired?
- How Long Is an SSL Certificate Valid?
- What Can I Do If an SSL Certificate Is About to Expire?
- How Long Does an SSL Certificate Take Effect After Being Purchased?
- Validity Periods and Replacement of the Current and New SSL Certificates
- How Can I Renew an SSL Certificate?
- How Do I Configure a Certificate Expiration Notification?
- Will Services Be Affected If an SSL Certificate Is Not Updated After It Expires?
- Validity Periods of Private Certificates
- How Long Will an Order Become Invalid If I Do Not Apply for a Certificate After Purchasing It?
- How Do I Know When My Certificate Expires?
- About Billing, Renewal, and Unsubscription
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Others
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SSL Certificate Management
- What Are the Differences Between Revoking a Certificate and Deleting a Certificate?
- Can I Withdraw a Certificate Revocation or Deletion Application?
- How Do I Convert a Certificate into the PEM Format?
- How Do I Complete the Certificate File When Uploading a Certificate?
- How Do I Configure a Certificate Chain?
- Why Is the SSL Certificate Not Displayed in the Certificate List?
- How Long Does It Take to Revoke a Certificate?
- Troubleshooting
- About Certificate Use
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SSL Certificate Management
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Certificate Consulting
- Videos
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More Documents
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User Guide (ME-Abu Dhabi Region)
- Service Overview
- Overview of Private Certificate Application
- Private CA Management
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Private Certificate Management
- Applying for a Private Certificate
- Downloading a Private Certificate
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Installing a Private Certificate
- Trusting a Private Root CA
- Installing a Private Certificate on a Client
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Installing a Private Certificate on a Server
- Installing a Private Certificate on a Tomcat Server
- Installing a Private Certificate on an Nginx Server
- Installing a Private Certificate on an Apache Server
- Installing a Private Certificate on an IIS Server
- Installing a Private Certificate on a WebLogic Server
- Installing a Private Certificate on a Resin Server
- Revoking a Private Certificate
- Viewing Details of a Private Certificate
- Deleting a Private Certificate
- Permissions Management
- FAQs
- Change History
- API Reference (ME-Abu Dhabi Region)
-
User Guide (ME-Abu Dhabi Region)
- General Reference
Copied.
Why Does the Browser Still Consider the Website Insecure While the Website Has an SSL Certificate Deployed?
Problem Description
After HTTPS is configured, the access to the website is still blocked, and a message is displayed indicating that the website is insecure.
Possible Causes
- Possible cause 1: The accessed domain name is not the same as the one associated with the purchased certificate.
- Possible cause 2: Non-HTTPS items, including images, CSS files, and JavaScript files, are incorrectly referenced to the website.
- Possible cause 3: The certificate has expired.
- Possible cause 4: The browser cache is large.
- Possible cause 5: The Website has been connected to Web Application Firewall (WAF), but the certificate used for the website in WAF was not updated.
Solution
Perform the following operations based on the possible cause:
- Possible cause 1: The accessed domain name is not the same as the one associated with the purchased certificate.
For example, the associated domain name is huaweicloud.com, but you are accessing https://yun.huaweicloud.com/. The certificate information is shown in Figure 1.
The purchased certificate is associated with huaweicloud.com and therefore it does not protect yun.huaweicloud.com. Either huaweicloud.com or yun.huaweicloud.com counts as a domain name. A single-domain certificate protects only the associated domain name.
Solution:
You are advised to request a certificate and associate it with the domain name you want to protect. For example, you can purchase a certificate and associate it with yun.huaweicloud.com. Then you can access https://yun.huaweicloud.com/.
If you have multiple domain names at the same level to be associated, for example, yun.huaweicloud.com, test.huaweicloud.com, and example.huaweicloud.com, which are all under *.huaweicloud.com, select Wildcard for the domain type when purchasing a certificate and associate the certificate with the wildcard domain name *.huaweicloud.com.
- Possible cause 2: Non-HTTPS items, including images, CSS files, and JavaScript files, are incorrectly referenced to the website.
When insecure HTTP items are referenced to an HTTPS web page, such as images, JavaScript files, CSS files, audio files, video files, and flash files, HTTP images referenced in CSS files, and insecure items written in JavaScript scripts are blocked by the browser by default. If you forcibly load the web page, a message is displayed indicating insecurity.
Solution:
- Open a web browser (Google Chrome 74 is used as an example) and access the web page to be checked.
- Press F12 to access Developer Tools. In the upper right corner, you can see which insecure web links affect the website.
Figure 2 Checking insecure links
- Find the reported insecure link and make sure it is an HTTP link.
Figure 3 Checking insecure items
- If the web link is useless, delete it. Then check whether the insecure link is cleared successfully.
- If the web link is important and cannot be deleted, change the HTTP path to an HTTPS path.
NOTICE:
If your website involves data like APIs, you are advised to contact the vendor that provides the invoked data. This is because APIs are important and cannot be modified randomly. If the vendor does not perform HTTPS authentication, you are advised not to perform authentication to prevent any errors in invoked data. For details, contact your vendor.
- After the processing is complete, clear the browser cache and access the website again.
- Possible cause 3: The certificate has expired.
If your SSL certificate has expired, a message will be displayed indicating insecurity when you access the associated domain name.
Solution:
Purchase a new certificate. For details, see What Can I Do If My SSL Certificate Expired?
- Possible cause 4: The browser cache is large.
Solution: Clear the browser cache or use another browser.
- Possible cause 5: The Website has been connected to Web Application Firewall (WAF), but the certificate used to the website in WAF was not updated.
- If you still need to use WAF, update the certificate in WAF. For details, see Updating a Certificate in WAF
- If WAF is no longer used, resolve the domain name to the origin server.
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