Help Center/ Cloud Application Engine/ FAQs/ Component Configuration FAQs/ What Do I Do If a Component Becomes Not Ready?
Updated on 2024-05-25 GMT+08:00

What Do I Do If a Component Becomes Not Ready?

Symptom

The component was not updated or restarted, but the component status automatically changed to Not ready, and then goes back to normal.

Possible Cause

During peak hours, there are many API requests, and the processes use too many CPU resources. As a result, the processes restart.

Solution

  • Configure an auto scaling policy for components. When the CPU usage exceeds the threshold, the number of instances automatically increases. For details, see Adding an AS Configuration.
  • Enable performance management, interconnect with APM 2.0, and monitor the API traffic to locate the cause of high CPU usage and the corresponding APIs. For details, see Configuring Performance Management.